Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 998435 - first access to Install page produces ISE with: com.redhat.rhn.common.db.WrappedSQLException: ERROR: query returned no rows
Summary: first access to Install page produces ISE with: com.redhat.rhn.common.db.Wrap...
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI
Version: 560
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tomas Lestach
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: sat560-triage
TreeView+ depends on / blocked
 
Reported: 2013-08-19 10:13 UTC by Jan Hutař
Modified: 2017-07-19 11:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-19 11:24:53 UTC


Attachments (Terms of Use)

Description Jan Hutař 2013-08-19 10:13:12 UTC
Description of problem:
I have registered RHEL5-Server-GOLD system and when I wanted to access page listing packages available for installation I got ISE


Version-Release number of selected component (if applicable):


How reproducible:
one of many attempts, seen it only for the first time accessing that page, but that could be coincidence


Steps to Reproduce:
1. Register RHEL5-Server-GOLD system into full RHEL5 channel
2. Go to System details -> Software -> Packages -> Install


Actual results:
ISE


Expected results:
Should work

Comment 2 Jan Hutař 2013-08-19 10:47:43 UTC
Forgot to provide versions:

satellite-schema-5.6.0.8-1.el6sat.noarch
spacewalk-java-2.0.2-15.el6sat.noarch

Comment 3 Tomas Lestach 2013-08-20 10:03:24 UTC
The trouble isn't really the page itself, but the DB exception you're getting.

According to the attached log an attempt to store packageEvr with values (epoch=0, version=0, release=0) fails and consequently (and not sure why) the appropriate lookup_evr function returns no rows. The other tomcat logs are just consequences of the exception.
There're more open questions, so let's start with the easy one:
What is the package you use with epoch=0, version=0, release=0 and where did you get it?
Was there any other thread running in parallel like satellite-sync, rhnpush, any other test?

Actually the DB exception isn't really expected, so it would be really interesting for us to know, how you achieved that and to have the chance to reproduce it.
We tried to create several tests, but the lookup_evr behaves like expected and not like on your machine.

Comment 4 Jan Hutař 2013-08-21 09:36:56 UTC
I have tried to reproduce but was not successful. I do not know what is the special step needed to get the ISE again. Sorry.

Comment 5 Tomas Lestach 2017-07-19 11:24:53 UTC
Based on Comment 4 I'm closing the BZ with INSUFFICIENT_DATA.


Note You need to log in before you can comment on or make changes to this bug.