Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 99473 - cdrecord "Fixating" fails with timeout
Summary: cdrecord "Fixating" fails with timeout
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: i386
OS: Linux
Target Milestone: ---
Assignee: Dave Jones
QA Contact:
Depends On:
Blocks: CambridgeBlocker
TreeView+ depends on / blocked
Reported: 2003-07-20 23:52 UTC by Warren Togami
Modified: 2015-01-04 22:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2004-02-15 02:42:04 UTC

Attachments (Terms of Use)

Description Warren Togami 2003-07-20 23:52:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:

These two kernels from Rawhide went kernel panic during "Fixating" of cdrecord.
 These messages were in my /var/log/messages after the reboot after each panic.

May 23 23:01:38 laptop kernel: scsi : aborting command due to timeout :
pid 1499608, scsi0, channel 0, id 0, lun 0 Test Unit Ready 00 00 00 00
Jul 20 13:35:35 laptop kernel: scsi : aborting command due to timeout : pid
8163829, scsi0, channel 0, id 0, lun 0 Test Unit Ready 00 00 00 00 00

Sony Vaio FXA-36 Athlon laptop
KT133A chipset

/dev/hda hard drive
/dev/hdc CD burner

I have been unable to get a crash dump of this yet.

Version-Release number of selected component (if applicable):

Comment 1 Michael K. Johnson 2003-10-21 20:11:29 UTC
Is this still a problem with latest kernels?

Comment 2 Dave Jones 2003-11-03 17:12:14 UTC
Also, without the actual oops, this is unlikely to get fixed as I've
been unable to reproduce locally.

Comment 3 Warren Togami 2003-11-03 18:19:09 UTC
I will attempt it again later today.

Comment 4 Warren Togami 2003-11-04 07:54:07 UTC
I tested the burning using this tiny ISO file.

These versions of kernels and cdrecord were tested, from FC1 and RH9.

It seems that whatever kernel bug was causing panics in earlier Severn
kernels has been fixed.  Now "Fixating" gets stuck for a very long
time.  While it is stuck it appears like this:

root      4844  4843  0 19:18 tty1     00:00:00 [cdrecord <defunct>]
root      4845  4710  0 19:19 tty2     00:00:00 -bash
root      4843  4780  0 19:18 tty1     00:00:00 cdrecord -v speed=1
dev=0,0,0 meroot      4908  4845  0 19:20 tty2     00:00:00 ps -ef
[root@laptop root]# strace -p 4843
Process 4843 attached - interrupt to quit
ioctl(3, 0x2285 <unfinished ...>
Process 4843 detached
[root@laptop root]# strace -p 4844
attach: ptrace(PTRACE_ATTACH, ...): Operation not permitted

Eventually it stops with these errors in dmesg:

scsi : aborting command due to timeout : pid 298, scsi0, channel 0, id
0, lun 0 Test Unit Ready 00 00 00 00 00 
scsi : aborting command due to timeout : pid 298, scsi0, channel 0, id
0, lun 0 Test Unit Ready 00 00 00 00 00 
SCSI host 0 abort (pid 298) timed out - resetting
SCSI bus is being reset for host 0 channel 0.
SCSI host 0 channel 0 reset (pid 298) timed out - trying harder
SCSI bus is being reset for host 0 channel 0.

Then cdrecord reports:

cdrecord: Cannot fixate disk.
Fixating time:  204.155s
cdrecord: fifo had 27 puts and 27 gets.
cdrecord: fifo was 0 times empty and 0 times full, min fill was 100%.

This was last working properly in pure RH9, so I tested the latest RH9
errata kernel and RH9 cdrecord.  It seems to not solve the problem. 
Should I try the original RH9 kernel too?  Any other ideas?

At least the kernel panic no longer happens...

Comment 5 Behdad Esfahbod 2003-11-05 13:47:02 UTC
I remember fixating working for me on updated RH9, which I burnt test2
ISOs, but it used to get locked (in your last case) with any vanilla
2.6 kernels.  BTW, just rebooted the machine and the CD was usable. 
Tried right now with kernel 2.4.22-1.2115.nptl and
cdrecord-2.01-0.a19.2 and worked like a charm.  Warren, can give it
another try?  I'm on a Sony Vaio P4M.

Comment 6 Warren Togami 2003-11-05 13:56:10 UTC
I gave this MULTIPLE tries across many reboots.  This is a real issue.

Comment 7 Dave Jones 2003-11-20 19:29:51 UTC
is DMA enabled on the CD drive? If it is, does disabling it fix it ?

Comment 8 Warren Togami 2003-12-14 09:22:08 UTC
Same behavior with DMA enabled or disabled.  DMA seems to be enabled
by default.

Comment 9 Warren Togami 2004-02-15 02:42:04 UTC
Well, I no longer care about this bug as I don't use 2.4 kernels
anymore.  REOPEN if anyone runs into this again.

Comment 10 Alexandre Strube 2004-06-28 14:31:11 UTC
This still happen. Downgrading to stock mkisofs and cdrecord works.

Note You need to log in before you can comment on or make changes to this bug.