Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 991685 - [RFE] Add ability to specify LDAP schema in order to be able to use Active Directory
Summary: [RFE] Add ability to specify LDAP schema in order to be able to use Active Di...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Pulp
Classification: Retired
Component: user-experience
Version: Master
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Sayli Karmarkar
QA Contact: Preethi Thomas
URL:
Whiteboard:
Depends On: 817063
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-08-03 15:42 UTC by redbugzilla
Modified: 2015-03-23 01:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-19 01:11:44 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Pulp Redmine 204 None None None Never

Description redbugzilla 2013-08-03 15:42:28 UTC
Description of problem:
There is already an RFE for specifying bind credentials, however the code assumes that username (for example) will match against an attribute called "uid".
See the ldap_filter in the function lookup_user in pulp/platform/src/pulp/server/auth/ldap_connection.py

This may not be true for all LDAP servers, for example Active Directory.

Version-Release number of selected component (if applicable):
2.1

How reproducible:
Always

Steps to Reproduce:
1. Have an LDAP server where username is not in an attribute called "uid"
2. LDAP authentication wont work because the user wont be found.
3.

Actual results:
Can't actually get this far, because we can't bind to AD with credentials yet.

Expected results:
Specify uid attribute as sAMAccountName
and others too, like:
gecos = displayName


Additional info:
Need to link this up with Bug 817063, since there is no point getting this done before that one; well for AD support anyway.

Comment 1 Brian Bouterse 2015-02-19 01:11:44 UTC
Moved to https://pulp.plan.io/issues/204


Note You need to log in before you can comment on or make changes to this bug.