Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 991620 - IndexError: list index out of range
Summary: IndexError: list index out of range
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.4
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Brian Lane
QA Contact: Release Test Team
URL:
Whiteboard: abrt_hash:1af88f567cf2d0de158cde8a23e...
: 1119383 (view as bug list)
Depends On:
Blocks: 1083985
TreeView+ depends on / blocked
 
Reported: 2013-08-03 03:05 UTC by yangfei
Modified: 2014-10-14 06:39 UTC (History)
5 users (show)

Fixed In Version: anaconda-13.21.221-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 06:39:17 UTC
Target Upstream Version:


Attachments (Terms of Use)
traceback - anaconda-13.21.220 (deleted)
2014-06-17 08:34 UTC, Petr Janda
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1145812 None None None Never
Red Hat Product Errata RHBA-2014:1380 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2014-10-14 01:10:50 UTC

Description yangfei 2013-08-03 03:05:08 UTC
Version-Release number of selected component:
anaconda-13.21.195

Additional info:
libreport version: 2.0.9
cmdline:        /usr/bin/python  /usr/bin/anaconda
kernel:         2.6.32-358.el6.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 13.21.195 exception report
:Traceback (most recent call first):
:  File "/usr/lib/anaconda/booty/x86.py", line 276, in writeGrubConf
:    f.write('#          root %s\n' % self.grubbyPartitionName(bootDevs[0]))
:  File "/usr/lib/anaconda/booty/x86.py", line 242, in writeGrub
:    cfPath)
:  File "/usr/lib/anaconda/booty/x86.py", line 535, in write
:    not self.useGrubVal)
:  File "/usr/lib/anaconda/bootloader.py", line 238, in writeBootloader
:    kernelList, otherList, defaultDev)
:  File "/usr/lib/anaconda/dispatch.py", line 210, in moveStep
:    rc = stepFunc(self.anaconda)
:  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
:    self.moveStep()
:  File "/usr/lib/anaconda/gui.py", line 1388, in nextClicked
:    self.anaconda.dispatch.gotoNext()
:  File "/usr/lib/anaconda/iw/progress_gui.py", line 79, in renderCallback
:    self.intf.icw.nextClicked()
:  File "/usr/lib/anaconda/gui.py", line 1409, in handleRenderCallback
:    self.currentWindow.renderCallback()
:IndexError: list index out of range

Comment 2 RHEL Product and Program Management 2013-10-14 02:51:39 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 3 tonioc 2014-01-23 19:33:20 UTC
just felt into this trap. 
I was trying to get a CentOS 6.5 on a new desktop PC (core-I3) in multi-boot beside the pre-installed W8. 
At the moment, I did not find a way to overcome it. 

Any idea or waorkaround for this issue would be welcome; 

regards,
antonio.

Comment 4 Petr Janda 2014-06-17 08:34:21 UTC
Created attachment 909468 [details]
traceback - anaconda-13.21.220

I have hit this bug recently during verification bug 974996.

Steps to reproduce:

1. On HDD old installation including EFI partition exists
2. Start new installation
3. Select "Custom partitioning"
4. Select proper partition/lvm for reformat as / DONOT select any EFI partition
5. Continue with default values

Current result
- anaconda does not complain about missing EFI partition
- anaconda fails with attached traceback during bootloader installation

Expected result
- installation without is /boot/efi is finished with warning or anaconda refuse to continue

Comment 5 RHEL Product and Program Management 2014-06-17 15:51:09 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.

Comment 6 Brian Lane 2014-06-17 17:15:22 UTC
Give this updates image a try. Add updates=http://bcl.fedorapeople.org/updates/991620.img to the kernel cmdline when booting to use it.

Comment 7 Petr Janda 2014-06-18 08:55:53 UTC
It is better - anaconda requires /boot/efi
But message it use is misleading a bit. Anaconda complains that user hasn`t  created /boot/efi partition, but with pre-existing one user has to reuse it - creating new does not help... and message is still the same - "You have not created /boot/efi partition"

Comment 9 Brian Lane 2014-07-18 00:57:57 UTC
*** Bug 1119383 has been marked as a duplicate of this bug. ***

Comment 10 Petr Janda 2014-09-10 11:16:24 UTC
OK, message is still same "You have not created /boot/efi partition" but it works.

verified on RHEL-6.6-20140903.0
anaconda 13.21.227

Comment 11 errata-xmlrpc 2014-10-14 06:39:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1380.html


Note You need to log in before you can comment on or make changes to this bug.