Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 991580 - /usr/libexec/rhsmd -s --debug is no longer debugging to stdout
Summary: /usr/libexec/rhsmd -s --debug is no longer debugging to stdout
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager
Version: 5.10
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Carter Kozak
QA Contact: IDM QE LIST
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel510
TreeView+ depends on / blocked
 
Reported: 2013-08-02 18:49 UTC by John Sefler
Modified: 2013-09-30 23:15 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Clone Of:
Environment:
Last Closed: 2013-09-30 23:15:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1332 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2013-09-30 22:49:24 UTC

Description John Sefler 2013-08-02 18:49:08 UTC
Description of problem:
/usr/libexec/rhsmd has a --debug option that is supposed to "Display debug messages".  This function seems to have regressed from former subscription-manager versions.  Currently no debug information is being displayed.

Steps to Reproduce:
Register system and then...
[root@jsefler-5 ~]# rpm -q subscription-manager python-rhsm
subscription-manager-1.8.15-1.el5
python-rhsm-1.8.15-1.el5
[root@jsefler-5 ~]# /usr/libexec/rhsmd -s --debug
[root@jsefler-5 ~]# 


Actual results:
nothing is being displayed to stdout


Expected results (taken from former version):
[root@rhsm-accept-rhel5 ~]# rpm -q subscription-manager python-rhsm
subscription-manager-1.0.24-1.el5
python-rhsm-1.0.10-1.el5
[root@rhsm-accept-rhel5 ~]# /usr/libexec/rhsmd -s --debug
System has one or more certificates that are not valid
['69']
[]
[root@rhsm-accept-rhel5 ~]# 


Additional info:
I suspect the lack of debug info is related to the new server-side compliance calculations versus the former client-side compliance calculations.

Comment 2 Carter Kozak 2013-08-05 15:18:08 UTC
commit dd9b53c39c27091d9185f9d53e5a3acae3905f7a
Author: ckozak <ckozak@redhat.com>
Date:   Fri Aug 2 15:02:49 2013 -0400

    991580: add rhsmd debug to stdout

Comment 5 Sharath Dwaral 2013-08-07 13:37:55 UTC
Version:

# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-gui-1.8.18-1.el5
subscription-manager-migration-data-1.11.3.2-1.git.0.14f9d59.el5
python-rhsm-1.8.16-1.el5
subscription-manager-migration-1.8.18-1.el5
subscription-manager-1.8.18-1.el5
subscription-manager-firstboot-1.8.18-1.el5
python-rhsm-debuginfo-1.8.16-1.el5
subscription-manager-debuginfo-1.8.18-1.el5

Verification:

System unregistered:

#  /usr/libexec/rhsmd -s --debug
The system is not currently registered.
In order for Subscription Manager to provide your system with updates, your system must be registered with the Customer Portal. Please enter your Red Hat login to ensure your system is up-to-date.

After Registering:

#  /usr/libexec/rhsmd -s --debug
This system is missing one or more subscriptions. Please run subscription-manager for more information.

Moving bug to VERIFIED

Comment 7 errata-xmlrpc 2013-09-30 23:15:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1332.html


Note You need to log in before you can comment on or make changes to this bug.