Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 991476 - Puppet doesn't install on F18 because the hiera dependency
Summary: Puppet doesn't install on F18 because the hiera dependency
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: puppet
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Sam Kottler
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-08-02 13:41 UTC by Sam Kottler
Modified: 2014-06-18 08:14 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-08-06 15:04:39 UTC


Attachments (Terms of Use)

Description Sam Kottler 2013-08-02 13:41:34 UTC
Description of problem:
Missing dependency on hiera.

Version-Release number of selected component (if applicable):
3.1.1-1

How reproducible:
Always.

Steps to Reproduce:
1. 'yum install puppet' on F18

Actual results:
--> Processing Dependency: rubygem(rdoc) >= 3.9.4 for package: rubygems-1.8.25-6.fc18.noarch
--> Processing Dependency: rubygem(io-console) >= 0.3 for package: rubygems-1.8.25-6.fc18.noarch
---> Package virt-what.x86_64 0:1.12-2.fc18 will be installed
--> Running transaction check
---> Package puppet.noarch 0:3.1.1-1.fc18 will be installed
--> Processing Dependency: hiera >= 1.0.0 for package: puppet-3.1.1-1.fc18.noarch
---> Package rubygem-io-console.x86_64 0:0.3-31.fc18 will be installed
---> Package rubygem-rdoc.noarch 0:3.12-6.fc18 will be installed
--> Processing Dependency: rubygem(json) < 2 for package: rubygem-rdoc-3.12-6.fc18.noarch
--> Processing Dependency: rubygem(json) >= 1.4 for package: rubygem-rdoc-3.12-6.fc18.noarch
--> Processing Dependency: ruby(irb) for package: rubygem-rdoc-3.12-6.fc18.noarch
--> Running transaction check
---> Package puppet.noarch 0:3.1.1-1.fc18 will be installed
--> Processing Dependency: hiera >= 1.0.0 for package: puppet-3.1.1-1.fc18.noarch
---> Package ruby-irb.noarch 0:1.9.3.448-31.fc18 will be installed
---> Package rubygem-json.x86_64 0:1.6.8-1.fc18 will be installed
--> Finished Dependency Resolution
Error: Package: puppet-3.1.1-1.fc18.noarch (updates)
           Requires: hiera >= 1.0.0
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Expected results:
The package and all its dependencies get installed.

Additional info:
This dependency was introduced by Moses Mendoza in 56cea400.

Comment 1 Pádraig Brady 2013-08-03 08:41:16 UTC
Does puppet need this hard dependency?

Steve any chance you could push this to stable in any case, thanks.

Comment 2 Sam Kottler 2013-08-04 21:07:58 UTC
I just committed a diff that removes the dependency on hiera as a stop-gap measure. The build is running now but might take longer than usual because of the load from the mass rebuild. Anyhow, once it's done I will submit an update.

Please test it and give it karma if it works.

Comment 3 Fedora Update System 2013-08-04 21:12:15 UTC
puppet-3.1.1-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/puppet-3.1.1-2.fc18

Comment 4 Steve Traylen 2013-08-05 07:13:26 UTC
Sure , will update and release.

Comment 5 Steve Traylen 2013-08-05 07:16:00 UTC
hiera 1.0.0 released, I'll follow up with an update as new one definitely has useful bug fixes.

Comment 6 Fedora Update System 2013-08-06 00:17:06 UTC
Package puppet-3.1.1-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing puppet-3.1.1-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14267/puppet-3.1.1-2.fc18
then log in and leave karma (feedback).

Comment 7 Sam Kottler 2013-08-06 15:04:39 UTC
I've unpushed this change and reverted it in git because hiera is now available in F18. I'm going to close this for now, but feel free to reopen it if there are any related subsequent problems.


Note You need to log in before you can comment on or make changes to this bug.