Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 991213 - snmpd hangs starting when sendmail queue groups are defined
Summary: snmpd hangs starting when sendmail queue groups are defined
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: net-snmp
Version: 6.4
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Jan Safranek
QA Contact: Dalibor Pospíšil
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-08-01 21:07 UTC by Kelsey Cummings
Modified: 2013-11-21 22:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: snmpd, the SNMP daemon, wrongly parsed Sendmail configuration files with enabled queue groups. Consequence: snmpd entered endless loop on startup. Fix: Parsing of the configuration file with queue groups was fixed. Result: snmpd does not enter endless loop.
Clone Of:
Environment:
Last Closed: 2013-11-21 22:52:05 UTC
Target Upstream Version:


Attachments (Terms of Use)
patch (deleted)
2013-08-01 21:07 UTC, Kelsey Cummings
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1693 normal SHIPPED_LIVE net-snmp bug fix and enhancement update 2013-11-20 21:52:17 UTC

Description Kelsey Cummings 2013-08-01 21:07:10 UTC
Created attachment 781775 [details]
patch

Description of problem:

A bug in the config parsing leads to a endless loop when it encounters queue groups defined in the cf.  Fixed upstream in 5.6


Version-Release number of selected component (if applicable):

5.5-44

How reproducible:

100%


Steps to Reproduce:
1. define sendmail queue group in sendmail.cf

eg:

cd /etc/mail;

add to sendmail.mc
define(`QUEUE_DIR', `/var/spool/mqueue/q*')dnl
QUEUE_GROUP(`mqueue', `F=f, I=1m, R=10')dnl 

make && make restart

2. attempt to start snmpd

Actual results:

It hangs.

Expected results:

It should start.


Additional info:

Patch is back ported from 5.6 and appears to fix the bug, allowing snmpd to start when sendmail queue groups are defined.

Comment 6 errata-xmlrpc 2013-11-21 22:52:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1693.html


Note You need to log in before you can comment on or make changes to this bug.