Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 991072 - Update what we display for unregistered systems that have no entitlement certs
Summary: Update what we display for unregistered systems that have no entitlement certs
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.0
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: 6.7
Assignee: candlepin-bugs
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel67
TreeView+ depends on / blocked
 
Reported: 2013-08-01 14:07 UTC by Matt Reid
Modified: 2015-05-15 19:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-07 15:18:03 UTC
Target Upstream Version:


Attachments (Terms of Use)
Unregistered System (deleted)
2013-08-01 14:09 UTC, Matt Reid
no flags Details

Description Matt Reid 2013-08-01 14:07:19 UTC
Description of problem:
Right now when a system is unregistered, we're kind of sending mixed signals. The status icon on My Installed Products is gray, as is the product icon in the table, and the table status text is Unknown. Yet, the Status string up top has our old string: "Keep your system up to date by registering.", and the Details pane says "System is not registered". If you run 'subscription-manager status', you also get 'Unknown' as the Overall Status, with no additional strings or context. 

For systems that are unregistered and do not have entitlement certs, I think we can be more clear and show their status as red, as well as list their status in the table as Not Registered, like we used to. If the system is kept unregistered, and entitlement certs are imported, then it makes sense to me to show Unknown like we do now.

Ideally, we should return 'Overall Status: Not Registered' from 'subscription-manager status' as well or at least add a string to the output that says their system isn't registered if we're going to continue to show Unknown there.



Version-Release number of selected component (if applicable):
subcription-manager-1.9.0-1.git

How reproducible:
Always

Steps to Reproduce:
1. Launch subscription-manager-gui
2. If needed, unregister your system

Actual results:
System shows Unknown in several places as its status

Expected results:
System should know that it isn't registered and doesn't have any entitlements imported and show itself as red, with a status of Unregistered

Additional info:

Comment 1 Matt Reid 2013-08-01 14:09:40 UTC
Created attachment 781615 [details]
Unregistered System

Comment 2 Bryan Kearney 2014-03-19 20:49:57 UTC
Moving bugs from 7.0 to 7.1

Comment 4 Bryan Kearney 2014-07-30 19:21:28 UTC
Acking 7.1

Comment 5 Devan Goodwin 2014-11-03 15:37:52 UTC
Additional caveat, this makes sense if the system is unregistered, has no entitlement certs, *and* has product certs. 

A lot of use cases like Satellite with Fedora / CentOS may have the client installed, they shouldn't be considered red if there are no product certs installed.

Deferring to 6.7 due to low priority.

Comment 9 Devan Goodwin 2015-04-07 15:18:03 UTC
Low priority, haven't been able to get to this in several releases and unlikely anytime soon. Closing for now, please reopen if major problems.


Note You need to log in before you can comment on or make changes to this bug.