Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 990984 - Report error when configure network with static IPv6 mode
Summary: Report error when configure network with static IPv6 mode
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.5.0
Assignee: Joey Boggs
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On:
Blocks: 1123329 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2013-08-01 10:40 UTC by wanghui
Modified: 2016-02-10 20:03 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 20:46:32 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC

Description wanghui 2013-08-01 10:40:14 UTC
Description of problem:
It reports "An error appeared in the UI: < InvalidData 'The field must contain a valid IPv6 address or an empty string.'>" when configure network with static IPv6 mode.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20130725.0.el6

How reproducible:
100%

Steps to Reproduce:
1. Install rhevh6.5.
2. Select a NIC and configure it with IPv6 Static mode.
   Bootprotocol :   ( ) Disabled   ( ) Auto     ( ) DHCP      ( ) Static
   IP Address   :   2001::10            Netmask :       64
   Gateway      :   2001::1

Actual results:
1. After step2, it reports "An error appeared in the UI: < InvalidData 'The field must contain a valid IPv6 address or an empty string.'> ".

Expected results:
1. After step2, it can set ipv6 address with static mode successfully.

Additional info:

Comment 5 wanghui 2013-11-04 02:39:53 UTC
Test version:
rhev-hypervisor6-6.5-20131031.1
ovirt-node-3.0.1-7.el6.noarch

Test steps:
1. Install rhevh6.5.
2. Select a NIC and configure it with IPv6 Static mode.
   Bootprotocol :   ( ) Disabled   ( ) Auto     ( ) DHCP      (*) Static
   IP Address   :   2001::100           Netmask :       48
   Gateway      :   2001::1

Test result:
1. After step2, it can set IPv6 address successfully.

This bug is fixed in rhev-hypervisor6-6.5-20131031.1. So I will change the status from ON_QA to VERIFIED.

Comment 7 wanghui 2014-01-13 11:39:32 UTC
Re-verify this issue.

Test version:
rhevh-6.5-20140110.1.iso
ovirt-node-3.0.1-16.el6_5.noarch

Test steps:
1. Install rhevh-6.5-20140110.1.iso.
2. Select a NIC and configure it with IPv6 Static mode.
   Bootprotocol :   ( ) Disabled   ( ) Auto     ( ) DHCP      (*) Static
   IP Address   :   2001::100           Netmask :       64
   Gateway      :   2001::1

Test result:
1. After step2, it can set IPv6 address successfully.

This bug is fixed in rhevh-6.5-20140110.1.iso.

Comment 9 Ying Cui 2014-07-29 11:19:18 UTC
Change this bug back to ON_QA, due to this bug flag is changed to rhev 3.5, we need to test and verify this bug on rhevh 7.0 and node 3.1.

Comment 10 wanghui 2014-12-18 06:20:37 UTC
Test Version:
rhev-hypervisor6-6.6-20141212.0.iso
ovirt-node-3.1.0-0.34.20141210git0c9c493.el6.noarch

Test step:
1. Install rhev-hypervisor6-6.6-20141212.0.iso.
2. Select a NIC and configure it with IPv6 Static mode.
   Bootprotocol :   ( ) Disabled   ( ) Auto     ( ) DHCP      (*) Static
   IP Address   :   2001::100           Netmask :       64
   Gateway      :   2001::1

Test result:
1. After step2, it can setup IPv6 address as static mode successfully.

So this issue is fixed in rhev-hypervisor6-6.6-20141212.0.iso. Also check no such issue in rhev-hypervisor7-7.0-20141212.0.iso. Change the status from ON_QA to Verified.

Comment 12 errata-xmlrpc 2015-02-11 20:46:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.