Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 990949 - packstack installation fails when L2 agents is selected as linuxbridge
Summary: packstack installation fails when L2 agents is selected as linuxbridge
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack
Version: 3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z2
: 3.0
Assignee: Terry Wilson
QA Contact: yfried
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-08-01 09:27 UTC by Dharmit Shah
Modified: 2018-12-02 15:59 UTC (History)
12 users (show)

Fixed In Version: openstack-packstack-2013.1.1-0.26.dev657.el6ost
Doc Type: Bug Fix
Doc Text:
Previously, if linuxbridge was selected as the L2 agent during a PackStack interactive installation, PackStack would fail with the error: ERROR : local variable 'iface_arr' referenced before assignment Please check log file /var/tmp/packstack/<timestamp>/openstack-setup.log for more information. This has been fixed and linuxbridge can be set as the L2 agent.
Clone Of:
Environment:
Last Closed: 2013-09-03 19:57:55 UTC
Target Upstream Version:


Attachments (Terms of Use)
openstack log (deleted)
2013-08-01 09:27 UTC, Dharmit Shah
no flags Details
Patch to list brige interfaces when 'linuxbridge' used as a L2 agent (deleted)
2013-08-01 09:36 UTC, Humble Chirammal
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 39727 None None None Never
Red Hat Product Errata RHBA-2013:1186 normal SHIPPED_LIVE Red Hat OpenStack 3.0 bug fix advisory 2013-09-03 23:55:39 UTC

Description Dharmit Shah 2013-08-01 09:27:45 UTC
Created attachment 781488 [details]
openstack log

Description of problem:
When "linuxbridge" is selected as L2 agent, packstack installation fails with below message:

    ERROR : local variable 'iface_arr' referenced before assignment
    Please check log file /var/tmp/packstack/20130730-060413-SraF4Q/openstack-setup.log for more information 

Version-Release number of selected component (if applicable):
openstack-packstack-2013.1.1-0.23.dev642.el6ost.noarch

How reproducible:
Always

Steps to Reproduce:
1. Install openstack-packstack-2013.1.1-0.23.dev642.el6ost.noarch
2. Run packstack
3. Select linuxbridge when asked for L2 agent.

Actual results:
Installation fails.

Expected results:
Installation should work fine.

Additional info:

Comment 3 Humble Chirammal 2013-08-01 09:36:37 UTC
Created attachment 781502 [details]
Patch to list brige interfaces when 'linuxbridge' used as a L2 agent

Comment 4 Humble Chirammal 2013-08-01 09:39:25 UTC
With this patch 'packstack' installation proceeded on Quantum L2 Agent manifest entries with 'linuxbridge' as L2 plugin.

quantum-dhcp-hosts:            10.65.209.157
quantum-l2-plugin:             linuxbridge
quantum-metadata-hosts:        10.65.209.157

******


Installing:
Clean Up...                                            [ DONE ]
OS support check...                                    [ DONE ]
Adding pre install manifest entries...                 [ DONE ]
Setting up ssh keys...                                 [ DONE ]
Adding MySQL manifest entries...                       [ DONE ]
Adding QPID manifest entries...                        [ DONE ]
Adding Keystone manifest entries...                    [ DONE ]
Adding Glance Keystone manifest entries...             [ DONE ]
Adding Glance manifest entries...                      [ DONE ]
Adding Cinder Keystone manifest entries...             [ DONE ]
Installing dependencies for Cinder...                  [ DONE ]
Checking if the Cinder server has a cinder-volumes vg...[ DONE ]
Adding Cinder manifest entries...                      [ DONE ]
Adding Nova API manifest entries...                    [ DONE ]
Adding Nova Keystone manifest entries...               [ DONE ]
Adding Nova Cert manifest entries...                   [ DONE ]
Adding Nova Conductor manifest entries...              [ DONE ]
Adding Nova Compute manifest entries...                [ DONE ]
Adding Nova Scheduler manifest entries...              [ DONE ]
Adding Nova VNC Proxy manifest entries...              [ DONE ]
Adding Nova Common manifest entries...                 [ DONE ]
Adding Openstack Network-related Nova manifest entries...[ DONE ]
Adding Quantum API manifest entries...                 [ DONE ]
Adding Quantum Keystone manifest entries...            [ DONE ]
Adding Quantum L3 manifest entries...                  [ DONE ]
Adding Quantum L2 Agent manifest entries...            [ DONE ]
Adding Quantum DHCP Agent manifest entries...          [ DONE ]
Adding Quantum Metadata Agent manifest entries...      [ DONE ]
Adding OpenStack Client manifest entries...            [ DONE ]
Adding Horizon manifest entries...                     [ DONE ]
Preparing servers...                                   [ DONE ]
Adding post install manifest entries...                [ DONE ]
Installing Dependencies...                             [ DONE ]
Copying Puppet modules and manifests...                [ DONE ]
Applying Puppet manifests...
Applying 10.65.209.157_prescript.pp
10.65.209.157_prescript.pp :                                         [ DONE ]
Applying 10.65.209.157_mysql.pp
Applying 10.65.209.157_qpid.pp
10.65.209.157_mysql.pp :                                             [ DONE ]
10.65.209.157_qpid.pp :                                              [ DONE ]
Applying 10.65.209.157_keystone.pp
Applying 10.65.209.157_glance.pp
Applying 10.65.209.157_cinder.pp
10.65.209.157_keystone.pp :                                          [ DONE ]
10.65.209.157_glance.pp :                                            [ DONE ]
10.65.209.157_cinder.pp :                                            [ DONE ]
Applying 10.65.209.157_api_nova.pp
10.65.209.157_api_nova.pp :                                          [ DONE ]
Applying 10.65.209.157_nova.pp
10.65.209.157_nova.pp :                                              [ DONE ]
Applying 10.65.209.157_quantum.pp
10.65.209.157_quantum.pp :                                           [ DONE ]
Applying 10.65.209.157_osclient.pp
Applying 10.65.209.157_horizon.pp
10.65.209.157_osclient.pp :                                          [ DONE ]
10.65.209.157_horizon.pp :                                           [ DONE ]
Applying 10.65.209.157_postscript.pp
10.65.209.157_postscript.pp :                                        [ DONE ]
                           [ DONE ]

 **** Installation completed successfully ******


I dont know how to check the other sanity checks though..

--Humble

Comment 5 Terry Wilson 2013-08-01 15:00:05 UTC
It is not an error that iface_arr is only defined with openvswitch. It is an error that is used when the l2 plugin is not openvswitch. So the attached patch won't work, but this https://review.openstack.org/39727 should fix the bug.

Comment 6 Humble Chirammal 2013-08-01 15:26:22 UTC
(In reply to Terry Wilson from comment #5)
> It is not an error that iface_arr is only defined with openvswitch. It is an
> error that is used when the l2 plugin is not openvswitch. So the attached
> patch won't work, but this https://review.openstack.org/39727 should fix the
> bug.

Terry, yep, I missed 'iface_arr' is only valid for openvswitch.

Comment 14 Ofer Blaut 2013-08-20 05:37:16 UTC
Tested on openstack-packstack-2013.1.1-0.27.dev660.el6ost.noarch

I have used LinuxBridge and no namespace

Comment 15 Bruce Reeler 2013-08-23 07:15:37 UTC
NEEDINFO for Terry Wilson:
I am writing the Doc Text for bug advisories. As the Doc Text field was blank, I have written the current Doc Text from scratch. Could you please edit it and correct as necessary, Thanks.

Comment 16 Terry Wilson 2013-08-23 15:37:16 UTC
Bruce Reeler: Doc text looks good to me.

Comment 18 errata-xmlrpc 2013-09-03 19:57:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1186.html


Note You need to log in before you can comment on or make changes to this bug.