Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 990919 - Auto install rhev-h failed with "Install instance has no attribute 'grub_dir'"
Summary: Auto install rhev-h failed with "Install instance has no attribute 'grub_dir'"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: unspecified
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.5.0
Assignee: Fabian Deutsch
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On: 1150377
Blocks: 1123329 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2013-08-01 08:29 UTC by haiyang,dong
Modified: 2016-02-10 20:08 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 20:46:26 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)
attached Screenshot (deleted)
2013-08-01 08:29 UTC, haiyang,dong
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC

Description haiyang,dong 2013-08-01 08:29:01 UTC
Created attachment 781473 [details]
attached Screenshot

Description of problem:
Make a usb livecd media via "livecd-iso-to-disk/dd" and boot rhev-h from this usb media.
Then Auto install rhev-h into real machine with follow parameters:
BOOTIF=eth0 storage_init=/dev/sda firstboot

but it failed with follow error info:
AttributeError: Install instance has no attribute 'grub_dir'(Seen AttributeError.JPG)

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20130725.0.el6

How reproducible:
100%

Steps to Reproduce:
1. Auto install rhev-h into real machine with follow parameter:
BOOTIF=eth0 storage_init=/dev/sda firstboot


Actual results:

Expected results:


Additional info:
No this issue when auto install rhev-h into virtual machine with the same parameters.

Comment 5 haiyang,dong 2013-11-02 07:22:22 UTC
Test version:
rhevh-6.5-20131031.1.0.iso
ovirt-node-3.0.1-7.el6

Make a usb livecd media via "livecd-iso-to-disk --format --reset-mbr/livecd-iso-to-disk --format --efi/dd" and boot rhev-h from this usb media.
Then Auto install rhev-h into real machine with follow parameters:
BOOTIF=eth0 storage_init=/dev/sda firstboot

it's successful to auto install rhev-h

so this bug has been fixed, after the status of this bug change into "ON_QA", i
will verify it.

Comment 6 haiyang,dong 2013-11-04 01:49:49 UTC
According to comment 5, change the status of this bug into "VERIFIED"

Comment 8 Ying Cui 2014-09-26 07:06:34 UTC
Change the status from VERIFIED to POST.

There is no rhevh build yet till now, so POST is good status for such bug.

Comment 10 Fabian Deutsch 2014-09-29 08:33:06 UTC
The state change on 2013-11-02 23:20:13 CET by Joey indicates that the bug landed long ago; please use the latest RHEV-H to verify this bug.

Comment 11 haiyang,dong 2014-11-12 12:38:42 UTC
Test version:
rhev-hypervisor6-6.6-20141107.0.iso
ovirt-node-3.1.0-0.25.20141107gitf6dc7b9.el6.noarch

Make a usb livecd media via "livecd-iso-to-disk --format --reset-mbr/livecd-iso-to-disk --format --efi/dd" and boot rhev-h from this usb media.
Then Auto install rhev-h into real machine with follow parameters:
BOOTIF=eth0 storage_init=/dev/sda firstboot

it's successful to auto install rhev-h

so this bug has been fixed in in rhevh 6.6 for RHEV 3.5 bulid version, change the status into "VERIFIED"

Comment 13 errata-xmlrpc 2015-02-11 20:46:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.