Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 990507 - virt-manager running on KDE do not show always CD-ROM connect box
Summary: virt-manager running on KDE do not show always CD-ROM connect box
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager
Version: 6.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 6.5
Assignee: Martin Kletzander
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-31 10:34 UTC by Martin Schuppert
Modified: 2018-12-03 19:29 UTC (History)
6 users (show)

Fixed In Version: virt-manager-0.9.0-19.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-11-21 20:40:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Article) 436733 None None None Never
Red Hat Product Errata RHBA-2013:1646 normal SHIPPED_LIVE virt-manager bug fix update 2013-11-20 21:53:27 UTC

Description Martin Schuppert 2013-07-31 10:34:57 UTC
Description of problem:
Using virt-manager to connect a physical or ISO CD-ROM image do not always work on KDE. The "Choose Media" box to select the image or physical device do not always show up under KDE. This happens only with KDE. After changing to Gnome the issue were not seen any more.

Version-Release number of selected component (if applicable):
* RHEL 6.4 
* virt-manager-0.9.0-18.el6.x86_64

How reproducible:
occasional, but when the window do not show up for a VM it stays like this until the KVM host or libvirtd/virt-manager will be restarted.

Steps to Reproduce:
Using virt-manager:
1. create new VM (just one virtio disk and the IDE CD-ROM)
2. go to VM details -> IDE CDROM1
3. press "Connect" button

Actual results:
sometimes for a VM the "Choose Media" window do not show up. 

Expected results:
"Choose Media" window always shows up when press the "Connect" button.

Additional info:
This issue were not seen using newer upstream version virt-manager-0.9.1

Comment 2 Martin Kletzander 2013-07-31 11:49:08 UTC
This is most likely fixed upstream with RELEASE-0.9.0-1-79-g5efe079:

commit 5efe079158b7b6e1fb9e8fcc00af8b27a08dbde3
Author: Cole Robinson <crobinso@redhat.com>
Date:   Wed Jan 25 10:38:42 2012 -0500

    Top level windows shouldn't be visible by default

Comment 5 hyao@redhat.com 2013-08-07 09:09:17 UTC
I reproduced the bug with the following package:
Version: 
virt-manager-0.9.0-18.el6.x86_64

Set the host with KDE 
Steps to Reproduce:
1. create new VM (just one virtio disk and the IDE CD-ROM)
2. go to VM details -> IDE CDROM1
3. press "Connect" button

Actural result:
"Choose Media" window doesn't pop up every time.



Verified

Version 
virt-manager-0.9.0-19.el6.x86_64

Set the host with KDE 
Steps to Reproduce:
1. create new VM (just one virtio disk and the IDE CD-ROM)
2. go to VM details -> IDE CDROM1
3. press "Connect" button

Result:
"Choose Media" window  pops up every time.

Comment 6 errata-xmlrpc 2013-11-21 20:40:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1646.html


Note You need to log in before you can comment on or make changes to this bug.