Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 990429 - [RHEVM][UI][TEXT] Comment tooltip is not well adjusted to its text
Summary: [RHEVM][UI][TEXT] Comment tooltip is not well adjusted to its text
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.3.0
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
: 3.4.0
Assignee: Greg Sheremeta
QA Contact: sefi litmanovich
URL:
Whiteboard: ux
Depends On:
Blocks: rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2013-07-31 08:12 UTC by Martin Pavlik
Modified: 2015-04-07 03:10 UTC (History)
9 users (show)

Fixed In Version: ovirt-3.4.0-alpha1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)
screenshot 1 (deleted)
2013-07-31 08:12 UTC, Martin Pavlik
no flags Details
screenshot 2 (deleted)
2013-07-31 08:13 UTC, Martin Pavlik
no flags Details
screenshot 2 (deleted)
2013-07-31 08:15 UTC, Martin Pavlik
no flags Details
screen-shot: other tooltips in the system (deleted)
2013-08-16 20:40 UTC, Einav Cohen
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 20201 None None None Never

Description Martin Pavlik 2013-07-31 08:12:44 UTC
Created attachment 780986 [details]
screenshot 1

Description of problem:
Tool-tip in comment field on Networks tab is not well adjusted to its content.

Case 1: tool tip text is short => box with tool-tip is 4 times wider than text (screenshot 1)
Case 2: tool tip text is long => text is cutted (screenshot 2)

Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Manager Version: 3.3.0-0.11.master.el6ev 

How reproducible:
100%

Steps to Reproduce:
1. Networks -> your network -> edit -> fill in comment -> confirm changes
2. hoover the mouse cursor over comment icon on networks tab

Actual results:
Tool-tip in comment field on Networks tab is not well adjusted to its content.

Expected results:
Better adjustment of the tooltip

Additional info:

Comment 1 Martin Pavlik 2013-07-31 08:13:25 UTC
Created attachment 780987 [details]
screenshot 2

Comment 2 Martin Pavlik 2013-07-31 08:15:17 UTC
Created attachment 780988 [details]
screenshot 2

Comment 3 Einav Cohen 2013-08-16 20:40:53 UTC
Created attachment 787460 [details]
screen-shot: other tooltips in the system

Comment 4 Einav Cohen 2013-08-16 20:44:17 UTC
we should probably use one of the tool-tips that are already being used in the system in other places (see attachment 787460 [details]) and seem to behave appropriately - I am not sure why another type of tool-tip has been introduced when the "comment" field was added to the system (Noam?)

Comment 5 Noam Slomianko 2013-08-19 09:13:37 UTC
Probably due to my lack of knowledge, switching them to InfoIcon for uniformity shouldn't be hard

Comment 9 Sandro Bonazzola 2014-01-14 08:43:41 UTC
ovirt 3.4.0 alpha has been released

Comment 10 sefi litmanovich 2014-01-30 14:55:19 UTC
Verified on ovirt-engine-3.4.0-0.5.beta1.el6.noarch

Comment 11 Itamar Heim 2014-06-12 14:09:43 UTC
Closing as part of 3.4.0


Note You need to log in before you can comment on or make changes to this bug.