Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 990282 - alsa-ucm.c: Assertion 'device->playback_channels || device->capture_channels' failed at modules/alsa/alsa-ucm.c:250, function ucm_get_device_property(). Aborting. [NEEDINFO]
Summary: alsa-ucm.c: Assertion 'device->playback_channels || device->capture_channels'...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 19
Hardware: arm
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-30 19:01 UTC by Erik Natvig
Modified: 2014-07-25 10:54 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-25 10:54:46 UTC
pbrobinson: needinfo? (thardobodol)


Attachments (Terms of Use)

Description Erik Natvig 2013-07-30 19:01:18 UTC
Description of problem:
F19 armv7hl, sound is not working.

Version-Release number of selected component (if applicable):
1.0.27

How reproducible:
Always

Steps to Reproduce:
1. from command line, run pulseaudio
2. E: [pulseaudio] alsa-ucm.c: Assertion 'device->playback_channels || device->capture_channels' failed at modules/alsa/alsa-ucm.c:250, function ucm_get_device_property(). Aborting.


Actual results:
No sound from speakers

Expected results:
Pretty sounds from speakers

Additional info:

journalctl | tail gives:

Jul 28 14:58:20 chromebook-f19 pulseaudio[835]: [pulseaudio] alsa-ucm.c: Assertion 'device->playback_channels || device->capture_channels' failed at modules/alsa/alsa-ucm.c:250, function ucm_get_device_property(). Aborting.
Jul 28 15:52:14 chromebook-f19 pulseaudio[23159]: [autospawn] core-util.c: Failed to create secure directory (/run/user/1000/pulse): Permission denied
Jul 28 15:52:15 chromebook-f19 pulseaudio[23161]: [autospawn] core-util.c: Failed to create secure directory (/run/user/1000/pulse): Permission denied
chromebook-f19 pulseaudio[1117]: [pulseaudio] alsa-ucm.c: Assertion 'device->playback_channels || device->capture_channels' failed at modules/alsa/alsa-ucm.c:250, function ucm_get_device_property(). Aborting.
Jul 30 14:44:01 chromebook-f19 pulseaudio[1122]: [pulseaudio] pid.c: Stale PID file, overwriting.
Jul 30 14:44:01 chromebook-f19 pulseaudio[1122]: [pulseaudio] alsa-ucm.c: Assertion 'device->playback_channels || device->capture_channels' failed at modules/alsa/alsa-ucm.c:250, function ucm_get_device_property(). Aborting.

Comment 1 Peter Robinson 2014-07-25 00:28:47 UTC
What kernel?

Comment 2 Tim Jackson 2014-07-25 10:38:51 UTC
Tis doesn't sound like a problem with alsa-tools. alsa-tools contains some specific tools for dealing with specialist sound cards only.

Comment 3 Peter Robinson 2014-07-25 10:54:46 UTC
The ARM chromebook is not a device we actually support in the kernel until F-21/3.16 and I'm not even sure the F-19 remix had appropriate UCM patches in the first place. Re-test on mainline F-21+ and if the issue is still there we'll deal with it then.


Note You need to log in before you can comment on or make changes to this bug.