Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 990059 - Strange behavior when trying to add VM without existing data domain
Summary: Strange behavior when trying to add VM without existing data domain
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.3.0
Assignee: Tomas Jelinek
QA Contact: sefi litmanovich
URL:
Whiteboard: virt
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-30 10:16 UTC by Lior Vernia
Modified: 2015-09-22 13:09 UTC (History)
7 users (show)

Fixed In Version: is15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 18885 None None None Never

Description Lior Vernia 2013-07-30 10:16:29 UTC
Description of problem:

When trying to add a VM, while there's not existing data domain, the dialog opens as usual but:
* The cluster and template UI fields remain empty.
* Nothing happens when pressing the arrow on the corresponding list box.
* The UI doesn't autocomplete text input by the user.
* If some text is input and OK is pressed, the GUI complains that they are empty even if there's text in them.

The real problem is, that none of these gives any hint as to the real reason that nothing works, that is that there's no data domain configured. Maybe it would be best if the dialog failed to open with a message explaining the reason? Or the button being disabled with an explanation?


Version-Release number of selected component (if applicable):

Working on oVirt 3.3 master branch.


How reproducible:

Always.


Steps to Reproduce:
1. Take clean environment.
2. Add host (probably same behavior without adding host).
3. Go the VMs tab and press "New VM".

Actual results:

Strange behavior that doesn't give a hint as to the real cause.


Expected results:

Some explanation related to the data domain.


Additional info:

Comment 1 Tomas Jelinek 2013-09-16 07:26:33 UTC
merged: d5e827e23ccc54120b4de93ae2a2d58f1bdb9868

Comment 2 sefi litmanovich 2013-09-22 14:22:57 UTC
Varified on rhevm 3.3, is15.
when trying to add vm while there is no data center and also when there is no host, the dialog opens with all fields unavailable and a message writen at the bottom:
Not available when no Data Center is up.

Comment 3 Itamar Heim 2014-01-21 22:29:51 UTC
Closing - RHEV 3.3 Released

Comment 4 Itamar Heim 2014-01-21 22:29:51 UTC
Closing - RHEV 3.3 Released

Comment 5 Itamar Heim 2014-01-21 22:32:52 UTC
Closing - RHEV 3.3 Released


Note You need to log in before you can comment on or make changes to this bug.