Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 989783 - [abrt] yum-utils-1.1.31-14.fc19: misc.py:1149:decompress:OSError: [Errno 2] No such file or directory: '/var/tmp/yum-branislav-sv_m9m/x86_64/19/fedora/gen/primary_db.sqlite'
Summary: [abrt] yum-utils-1.1.31-14.fc19: misc.py:1149:decompress:OSError: [Errno 2] N...
Keywords:
Status: CLOSED DUPLICATE of bug 969776
Alias: None
Product: Fedora
Classification: Fedora
Component: yum-utils
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:6920f227e6f8bcf58cbb1d650ee...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-29 22:52 UTC by Branislav Blaškovič
Modified: 2013-07-30 07:39 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-30 07:39:53 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2013-07-29 22:52 UTC, Branislav Blaškovič
no flags Details
File: core_backtrace (deleted)
2013-07-29 22:52 UTC, Branislav Blaškovič
no flags Details
File: environ (deleted)
2013-07-29 22:52 UTC, Branislav Blaškovič
no flags Details

Description Branislav Blaškovič 2013-07-29 22:52:21 UTC
Description of problem:
I've runned fedora-gooey-karma which I develop.
Sources: https://github.com/blaskovic/fedora-gooey-karma/tree/933352a1602937639286fc3dc3011ce56320eb43

Version-Release number of selected component:
yum-utils-1.1.31-14.fc19

Additional info:
reporter:       libreport-2.1.5
cmdline:        /usr/bin/python -tt /usr/bin/repoquery -q --qf %{name} --whatrequires qt
dso_list:       yum-3.4.3-99.fc19.noarch
executable:     /usr/bin/repoquery
kernel:         3.9.5-301.fc19.x86_64
runlevel:       N 5
uid:            1001

Truncated backtrace:
misc.py:1149:decompress:OSError: [Errno 2] No such file or directory: '/var/tmp/yum-branislav-sv_m9m/x86_64/19/fedora/gen/primary_db.sqlite'

Traceback (most recent call last):
  File "/usr/bin/repoquery", line 1529, in <module>
    main(sys.argv)
  File "/usr/bin/repoquery", line 1519, in main
    repoq.runQuery(regexs)
  File "/usr/bin/repoquery", line 995, in runQuery
    for p in self.doQuery(oper, prco):
  File "/usr/bin/repoquery", line 1034, in doQuery
    return getattr(self, "fmt_%s" % method)(*args, **kw)
  File "/usr/bin/repoquery", line 1073, in fmt_whatrequires
    require_recursive(name)
  File "/usr/bin/repoquery", line 1058, in require_recursive
    for pkg in self.returnByName(name):
  File "/usr/bin/repoquery", line 842, in returnByName
    pkgs = self.returnPkgList(patterns=[name])
  File "/usr/bin/repoquery", line 859, in returnPkgList
    pkgs = self.pkgSack.returnNewestByNameArch(**kwargs)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1050, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 770, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 387, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 231, in populate
    db_un_fn = self._check_uncompressed_db_gen(repo, mydbtype)
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 284, in _check_uncompressed_db_gen
    cached=repo.cache)
  File "/usr/lib/python2.7/site-packages/yum/misc.py", line 1161, in repo_gen_decompress
    ret = decompress(filename, dest=dest, check_timestamps=True,fn_only=cached)
  File "/usr/lib/python2.7/site-packages/yum/misc.py", line 1149, in decompress
    os.utime(out, (fi.st_mtime, fi.st_mtime))
OSError: [Errno 2] No such file or directory: '/var/tmp/yum-branislav-sv_m9m/x86_64/19/fedora/gen/primary_db.sqlite'

Local variables in innermost frame:
check_timestamps: True
dest: '/var/tmp/yum-branislav-sv_m9m/x86_64/19/fedora/gen/primary_db.sqlite'
filename: '/var/tmp/yum-branislav-sv_m9m/x86_64/19/fedora/e7ce86939c0cf46323cd42db1461adabda3cf5a31408b7339d7cf2f074a8bb39-primary.sqlite.bz2'
fo: None
fi: posix.stat_result(st_mode=33188, st_ino=419033, st_dev=64515L, st_nlink=1, st_uid=1001, st_gid=1001, st_size=18300372, st_atime=1375138105, st_mtime=1372419845, st_ctime=1375138105)
out: '/var/tmp/yum-branislav-sv_m9m/x86_64/19/fedora/gen/primary_db.sqlite'
fn_only: 0
ztype: 'bz2'

Comment 1 Branislav Blaškovič 2013-07-29 22:52:27 UTC
Created attachment 780163 [details]
File: backtrace

Comment 2 Branislav Blaškovič 2013-07-29 22:52:32 UTC
Created attachment 780164 [details]
File: core_backtrace

Comment 3 Branislav Blaškovič 2013-07-29 22:52:36 UTC
Created attachment 780165 [details]
File: environ

Comment 4 Branislav Blaškovič 2013-07-29 22:56:43 UTC
The problem was in repoquery which is spawned by subprocess in fedora-gooey-karma. So it's NOT relevant to fedora-gooey-karma probably.

Comment 5 Zdeněk Pavlas 2013-07-30 07:39:53 UTC
We wrote the decompressed file in decompress() just before os.utime(), there's no other code path.  It must have been a race. Closing as a dupe of of BZ 969776, that was not fixed in -14.

*** This bug has been marked as a duplicate of bug 969776 ***


Note You need to log in before you can comment on or make changes to this bug.