Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 989695 - The value of existing IPs are getting modified during incompatible migrations
Summary: The value of existing IPs are getting modified during incompatible migrations
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Containers
Version: 2.x
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Paul Morie
QA Contact: libra bugs
URL:
Whiteboard:
: 989413 989463 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-29 18:11 UTC by Mrunal Patel
Modified: 2015-05-14 23:25 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-08-07 22:57:47 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Mrunal Patel 2013-07-29 18:11:57 UTC
Description of problem:
The value of IP variables for an application are getting modified during 
an incompatible migration

Version-Release number of selected component (if applicable):




Steps to Reproduce:
1. Run an incompatible migration for a scalable application.


Actual results:
The values of OPENSHIFT_HAPROXY_IP/OPENSHIFT_HAPROXY_STATUS_IP change.

Expected results:
They should remain the same.

Comment 1 Jason DeTiberus 2013-07-29 20:01:40 UTC
*** Bug 989413 has been marked as a duplicate of this bug. ***

Comment 2 Paul Morie 2013-07-30 20:49:36 UTC
PR submitted.

Comment 3 Paul Morie 2013-07-30 21:03:18 UTC
*** Bug 989463 has been marked as a duplicate of this bug. ***

Comment 4 openshift-github-bot 2013-07-30 22:00:07 UTC
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/dbdde92e1e84df79983ecfd6d942d77e28b04d5d
Fix bug 989695: do not reallocate existing IPs during incompatible upgrade

Comment 5 Jianwei Hou 2013-07-31 09:40:41 UTC
Verified on devenv_3588

After incompatible cartridge migration, the app are still accessible, the IPs are not changed.


Note You need to log in before you can comment on or make changes to this bug.