Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 989145 - Typo in preun scriptlet
Summary: Typo in preun scriptlet
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kde-settings
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Bříza
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: https://fedoraproject.org/wiki/Common...
: 980899 994470 998139 1000550 1015901 1058361 1078637 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-27 22:02 UTC by Sandro Mani
Modified: 2014-03-20 10:05 UTC (History)
19 users (show)

Fixed In Version: kde-settings-19-23.1.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-08-06 23:39:15 UTC


Attachments (Terms of Use)

Description Sandro Mani 2013-07-27 22:02:28 UTC
Description of problem:
In this section of the spec file:
%preun kdm
%{?systemd_preun:%system_preun kdm.service}

There is a typo:
%{?systemd_preun:%system_preun kdm.service}
should read
%{?systemd_preun:%systemd_preun kdm.service}

Otherwise the preun scriptlet fails and the only way to remove the package is by rpm -e --noscripts.

Version-Release number of selected component (if applicable):
kde-settings-kdm-19-23.fc20.noarch

Comment 1 Martin Bříza 2013-07-29 09:12:00 UTC
Hi Sandro,
thanks for your report! I'm fixing the problem right now and will push the update in a minute.

Comment 2 Fedora Update System 2013-07-29 09:14:14 UTC
kde-settings-19-23.1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kde-settings-19-23.1.fc19

Comment 3 Sandro Mani 2013-07-29 10:19:54 UTC
Thanks for the quick response!

Comment 4 Fedora Update System 2013-07-30 17:46:38 UTC
Package kde-settings-19-23.1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kde-settings-19-23.1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13897/kde-settings-19-23.1.fc19
then log in and leave karma (feedback).

Comment 5 Martin Bříza 2013-08-01 08:05:56 UTC
*** Bug 980899 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2013-08-06 23:39:15 UTC
kde-settings-19-23.1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Kevin Kofler 2013-08-09 21:35:35 UTC
*** Bug 994470 has been marked as a duplicate of this bug. ***

Comment 8 Lars Gullik Bjønnes 2013-08-12 19:37:31 UTC
(In reply to Fedora Update System from comment #6)
> kde-settings-19-23.1.fc19 has been pushed to the Fedora 19 stable
> repository.  If problems still persist, please make note of it in this bug
> report.

Unable to remove the 19-23 package:

yum remove kde-settings-kdm-19-23.fc19.noarch:

Running transaction
/var/tmp/rpm-tmp.qFaQ4E: line 1: fg: no job control
error: %preun(kde-settings-kdm-19-23.fc19.noarch) scriptlet failed, exit status 1
Error in PREUN scriptlet in rpm package kde-settings-kdm-19-23.fc19.noarch
  Verifying  : kde-settings-kdm-19-23.fc19.noarch                                     1/1 

Failed:
  kde-settings-kdm.noarch 0:19-23.fc19                                                    

Complete!

Comment 9 Sandro Mani 2013-08-12 19:48:36 UTC
Yeah, that is what this update fixes. To remove the old package, your only option is
# rpm -e --noscripts kde-settings-kdm-19-23.fc19.noarch

I still think that bodhi should check whether packages are removable as an auto-qa step, since such cases are really not user friendly, but there was not much feedback when I posted to devel: https://lists.fedoraproject.org/pipermail/devel/2013-July/186910.html

Comment 10 Rex Dieter 2013-08-17 17:07:13 UTC
*** Bug 998139 has been marked as a duplicate of this bug. ***

Comment 11 Rex Dieter 2013-08-26 13:05:33 UTC
*** Bug 1000550 has been marked as a duplicate of this bug. ***

Comment 12 Rex Dieter 2013-10-07 14:36:01 UTC
*** Bug 1015901 has been marked as a duplicate of this bug. ***

Comment 13 Adam Williamson 2013-12-30 06:12:27 UTC
Sandro: FWIW, we aren't planning to add any new tests to AutoQA, instead development is focused on getting Taskotron (its replacement) up and running.

Comment 14 Rex Dieter 2014-01-27 17:46:15 UTC
*** Bug 1058361 has been marked as a duplicate of this bug. ***

Comment 15 Kevin Kofler 2014-03-20 10:05:48 UTC
*** Bug 1078637 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.