Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 989045 - by default glusterfsd.service enters failed state on boot
Summary: by default glusterfsd.service enters failed state on boot
Keywords:
Status: CLOSED DUPLICATE of bug 1022542
Alias: None
Product: Fedora
Classification: Fedora
Component: glusterfs
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kaleb KEITHLEY
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-27 04:56 UTC by Chris Murphy
Modified: 2016-11-17 07:01 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-10-31 11:50:12 UTC


Attachments (Terms of Use)

Description Chris Murphy 2013-07-27 04:56:58 UTC
Description of problem: On default Fedora 19 install, and after updating, glusterfsd enters failed state.


Version-Release number of selected component (if applicable):
glusterfs-3.4.0-2.fc19.x86_64
glusterfs-server-3.4.0-2.fc19.x86_64
glusterfs-geo-replication-3.4.0-2.fc19.x86_64
glusterfs-api-3.4.0-2.fc19.x86_64
glusterfs-fuse-3.4.0-2.fc19.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora 19 and reboot. Optionally update to current, then rebot.
2. journalctl -b -u glusterfsd
3.

Actual results:

Jul 26 22:43:43 f19sv1.local systemd[1]: Starting GlusterFS an clustered file-system server...
Jul 26 22:43:43 f19sv1.local glusterfsd[282]: [2013-07-27 04:43:43.959907] C [glusterfsd.c:1406:parse_cmdline] 0-glusterfs: ERROR: parsing the volfile failed (No such file or directory)
Jul 26 22:43:43 f19sv1.local GlusterFS[282]: [2013-07-27 04:43:43.959907] C [glusterfsd.c:1406:parse_cmdline] 0-glusterfs: ERROR: parsing the volfile failed (No such file or directory)
Jul 26 22:43:43 f19sv1.local glusterfsd[282]: USAGE: /usr/sbin/glusterfsd [options] [mountpoint]
Jul 26 22:43:43 f19sv1.local systemd[1]: glusterfsd.service: control process exited, code=exited status=255
Jul 26 22:43:43 f19sv1.local systemd[1]: Failed to start GlusterFS an clustered file-system server.
Jul 26 22:43:43 f19sv1.local systemd[1]: Unit glusterfsd.service entered failed state.


Expected results:
It's installed and enabled by default, so it should successfully start. Alternatively if it can't be made to successfully start unless configured first, it should be disabled by default to avoid the failure status message on every boot.

Additional info:
Bug 980683, AVC denial of glusterfs has been fixed, no AVC denial is occurring so that's not what's causing this failure to start.

Comment 1 Kaleb KEITHLEY 2013-10-31 11:50:12 UTC
fixed in glusterfs-3.4.1-3

*** This bug has been marked as a duplicate of bug 1022542 ***

Comment 2 Sonal 2016-11-17 07:01:43 UTC
I am facing the same issue on fedora24 for glusterfs-3.8.5-1.
Can anybody give solution to fix this


Note You need to log in before you can comment on or make changes to this bug.