Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 988950 - Deleting GPG key associated with a product renders database error
Summary: Deleting GPG key associated with a product renders database error
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer
Version: Nightly
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Petr Chalupa
QA Contact: Garik Khachikyan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-26 18:56 UTC by Apurva Bhole
Modified: 2015-05-05 01:30 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-24 17:09:06 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Apurva Bhole 2013-07-26 18:56:52 UTC
Description of problem:
Unable to delete a GPG key that is associated with a product.

Version-Release number of selected component (if applicable):

katello-selinux-1.4.3-1.git.4.99dc194.el6.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-all-1.4.2-1.git.983.e3af4c9.el6.noarch
katello-cli-common-1.4.2-1.git.137.fea0d84.el6.noarch
katello-configure-1.4.3-1.git.67.f71e590.el6.noarch
signo-katello-0.0.9-1.el6.noarch
katello-glue-pulp-1.4.2-1.git.983.e3af4c9.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.2-1.el6.noarch
katello-common-1.4.2-1.git.983.e3af4c9.el6.noarch
katello-glue-candlepin-1.4.2-1.git.983.e3af4c9.el6.noarch
katello-1.4.2-1.git.983.e3af4c9.el6.noarch
katello-repos-1.4.2-1.el6.noarch
katello-cli-1.4.2-1.git.137.fea0d84.el6.noarch
katello-glue-elasticsearch-1.4.2-1.git.983.e3af4c9.el6.noarch
katello-qpid-client-key-pair-1.0-1.noarch


How reproducible:
Everytime

Steps to Reproduce:
1. provider create --name FirstProv --org ACME_Corporation
2. product create --name FirstProd --provider FirstProv --org ACME_Corporation
3. gpg_key create --name FirstKey --org ACME_Corporation
4. product update --name FirstProd --gpgkey FirstKey --org ACME_Corporation
5. repo create --name FirstRepo --org ACME_Corporation --product FirstProd --url $repoURL
6. gpg_key delete --name FirstKey --org ACME_Corporation

Actual results:
ERROR:  update or delete on table "gpg_keys" violates foreign key constraint "products_gpg_key_id_fk" on table "products"
DETAIL:  Key (id)=(1) is still referenced from table "products".

Expected results:
Successful gpg key deletion

Comment 1 RHEL Product and Program Management 2013-09-17 04:21:41 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 6 Petr Chalupa 2013-10-11 14:41:45 UTC
fixed in 6a40eba9618409b004807484fdb0dcf1a6d9f60a

Comment 9 Garik Khachikyan 2013-10-18 14:26:52 UTC
# VERIFIED

automation passes ok now on this.

checked against:
===
candlepin-0.8.25-1.el6sam.noarch
candlepin-cert-consumer-demeter.usersys.redhat.com-1.0-1.noarch
candlepin-scl-1-5.el6_4.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
candlepin-selinux-0.8.25-1.el6sam.noarch
candlepin-tomcat6-0.8.25-1.el6sam.noarch
createrepo-0.9.9-21.2.pulp.el6sat.noarch
elasticsearch-0.19.9-8.el6sat.noarch
katello-1.4.6-40.el6sat.noarch
katello-agent-1.4.4-3.el6sat.noarch
katello-all-1.4.6-40.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.4-1.el6sat.noarch
katello-cli-1.4.3-24.el6sat.noarch
katello-cli-common-1.4.3-24.el6sat.noarch
katello-common-1.4.6-40.el6sat.noarch
katello-configure-1.4.7-6.el6sat.noarch
katello-configure-foreman-1.4.7-6.el6sat.noarch
katello-foreman-all-1.4.6-40.el6sat.noarch
katello-glue-candlepin-1.4.6-40.el6sat.noarch
katello-glue-elasticsearch-1.4.6-40.el6sat.noarch
katello-glue-pulp-1.4.6-40.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-selinux-1.4.4-4.el6sat.noarch
m2crypto-0.21.1.pulp-8.el6sat.x86_64
mod_wsgi-3.4-1.pulp.el6sat.x86_64
pulp-katello-plugins-0.2-1.el6sat.noarch
pulp-nodes-common-2.3.0-0.22.beta.el6sat.noarch
pulp-nodes-parent-2.3.0-0.22.beta.el6sat.noarch
pulp-puppet-plugins-2.3.0-0.22.beta.el6sat.noarch
pulp-rpm-handlers-2.3.0-0.22.beta.el6sat.noarch
pulp-rpm-plugins-2.3.0-0.22.beta.el6sat.noarch
pulp-selinux-2.3.0-0.22.beta.el6sat.noarch
pulp-server-2.3.0-0.22.beta.el6sat.noarch
python-isodate-0.5.0-1.pulp.el6sat.noarch
python-oauth2-1.5.170-3.pulp.el6sat.noarch
python-pulp-agent-lib-2.3.0-0.22.beta.el6sat.noarch
python-pulp-bindings-2.3.0-0.22.beta.el6sat.noarch
python-pulp-common-2.3.0-0.22.beta.el6sat.noarch
python-pulp-puppet-common-2.3.0-0.22.beta.el6sat.noarch
python-pulp-rpm-common-2.3.0-0.22.beta.el6sat.noarch
python-qpid-0.18-5.el6_4.noarch
qpid-cpp-client-0.14-22.el6_3.x86_64
qpid-cpp-client-ssl-0.14-22.el6_3.x86_64
qpid-cpp-server-0.14-22.el6_3.x86_64
qpid-cpp-server-ssl-0.14-22.el6_3.x86_64
ruby193-rubygem-foreman-katello-engine-0.0.17-6.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.12-3.el6sat.noarch
ruby193-rubygem-katello_api-0.0.3-4.el6sat.noarch
ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
signo-katello-0.0.23-2.el6sat.noarch

Comment 13 Bryan Kearney 2014-04-24 17:09:06 UTC
This was verified and delivered with MDP2. Closing it out.

Comment 14 Bryan Kearney 2014-04-24 17:10:41 UTC
This was delivered and verified with MDP2. Closing the bug.


Note You need to log in before you can comment on or make changes to this bug.