Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 988943 - ACL doesn't work with FUSE mounted GlusterFS
Summary: ACL doesn't work with FUSE mounted GlusterFS
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: access-control
Version: 3.4.0
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-26 18:22 UTC by Richard
Modified: 2015-05-27 13:29 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-27 13:29:13 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Richard 2013-07-26 18:22:38 UTC
Description of problem: Setting ACL on a FUSE mounted GlusterFS Volume doesn't work (but it does work when NFS mounting Gluster Volume).

Steps to Reproduce:
1. Setup a new disk with xfs as the FS format.
2. Create a new volume using this disk for storage
3. mount this new volume using: mount -t glusterfs -o acl 127.0.0.1:/vol /mnt/vol
4. cd into /mnt/vol
5. create a new file: touch acl-test
6. try set ACL: setfacl -m u:gopher:rw acl-test
7. check ACL is set: getfacl acl-test 

Actual results: No ACL set


Expected results: gopher user to be added into ACL list.

Using Gluster 3.4 available in the public Gluster Repo:
glusterfs-fuse-3.4.0-3.fc18.x86_64
glusterfs-3.4.0-3.fc18.x86_64
glusterfs-api-3.4.0-3.fc18.x86_64
glusterfs-server-3.4.0-3.fc18.x86_64

Comment 1 Christopher R. Hertel 2013-08-14 16:41:40 UTC
Possibly related:
  https://bugzilla.redhat.com/show_bug.cgi?id=989435

Comment 2 Richard 2013-08-14 17:49:15 UTC
(In reply to Christopher R. Hertel from comment #1)
> Possibly related:
>   https://bugzilla.redhat.com/show_bug.cgi?id=989435

yes, I can confirm that by running "gluster volume set <VOL> stat-prefetch disable" ACL's are now working.

Thanks for the tip.

Rich

Comment 4 Niels de Vos 2015-05-17 22:00:28 UTC
GlusterFS 3.7.0 has been released (http://www.gluster.org/pipermail/gluster-users/2015-May/021901.html), and the Gluster project maintains N-2 supported releases. The last two releases before 3.7 are still maintained, at the moment these are 3.6 and 3.5.

This bug has been filed against the 3,4 release, and will not get fixed in a 3.4 version any more. Please verify if newer versions are affected with the reported problem. If that is the case, update the bug with a note, and update the version if you can. In case updating the version is not possible, leave a comment in this bug report with the version you tested, and set the "Need additional information the selected bugs from" below the comment box to "bugs@gluster.org".

If there is no response by the end of the month, this bug will get automatically closed.

Comment 5 Richard 2015-05-27 13:28:23 UTC
This now works for me with v3.4.7 without setting stat-prefetch to disable :-)


Note You need to log in before you can comment on or make changes to this bug.