Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 988804 - user 'admin' cannot start a new task in task list
Summary: user 'admin' cannot start a new task in task list
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss BPMS Platform 6
Classification: Retired
Component: Business Central
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ER3
: 6.0.0
Assignee: Maciej Swiderski
QA Contact: Jan Hrcek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-26 12:48 UTC by Jan Hrcek
Modified: 2013-09-20 12:10 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-20 12:10:13 UTC
Type: Bug


Attachments (Terms of Use)

Description Jan Hrcek 2013-07-26 12:48:33 UTC
Description of problem:
This is followup on issue described in detail here: https://bugzilla.redhat.com/show_bug.cgi?id=988770 - see comment 3.

Comment 1 Maciej Swiderski 2013-08-06 11:30:35 UTC
the issue is in fact caused by same name of user and group - user admin that is member of group admin. Since users and groups in task service are kept in same table that causes constraint violation when storing second entity.

Making user and group names unique allows to use admin as a task user.

See similar case here: https://bugzilla.redhat.com/show_bug.cgi?id=990620

Marking this as modified as it works as designed.

Comment 2 Marek Baluch 2013-08-14 08:33:47 UTC
Hi Maciej - it probably does not matter weather a group is called 'admin' or 'admins'. I agree with that.

Since this issues ha been acked by PM I want to make sure before we close this as WONTFIX. Rajesh can add a comment please?

Thanks.


Note You need to log in before you can comment on or make changes to this bug.