Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 988656 - display an error message instead of a bug reporting dialog for this: KickstartValueError: The following problem occurred on line 32 of the kickstart file: The volume group name "fedora_1" is already in use.
Summary: display an error message instead of a bug reporting dialog for this: Kickstar...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:16fa2b3f6b44cdbc5f46ef2338c...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-26 05:15 UTC by Steve Tyler
Modified: 2014-01-29 20:44 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-29 20:44:29 UTC


Attachments (Terms of Use)
File: anaconda-tb (deleted)
2013-07-26 05:15 UTC, Steve Tyler
no flags Details
File: anaconda.log (deleted)
2013-07-26 05:15 UTC, Steve Tyler
no flags Details
File: environ (deleted)
2013-07-26 05:16 UTC, Steve Tyler
no flags Details
File: ks.cfg (deleted)
2013-07-26 05:16 UTC, Steve Tyler
no flags Details
File: lsblk_output (deleted)
2013-07-26 05:16 UTC, Steve Tyler
no flags Details
File: nmcli_dev_list (deleted)
2013-07-26 05:16 UTC, Steve Tyler
no flags Details
File: os_info (deleted)
2013-07-26 05:16 UTC, Steve Tyler
no flags Details
File: program.log (deleted)
2013-07-26 05:16 UTC, Steve Tyler
no flags Details
File: storage.log (deleted)
2013-07-26 05:16 UTC, Steve Tyler
no flags Details
File: syslog (deleted)
2013-07-26 05:16 UTC, Steve Tyler
no flags Details
File: ifcfg.log (deleted)
2013-07-26 05:16 UTC, Steve Tyler
no flags Details
File: packaging.log (deleted)
2013-07-26 05:16 UTC, Steve Tyler
no flags Details

Description Steve Tyler 2013-07-26 05:15:47 UTC
Description of problem:
Attempt to reproduce Bug 988530 using a modified /root/anaconda-ks.cfg from a minimal install with Manual Partitioning.

Version-Release number of selected component:
anaconda-19.30.13-1

The following was filed automatically by anaconda:
anaconda 19.30.13-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 1353, in execute
    raise KickstartValueError(formatErrorMsg(self.lineno, msg="The volume group name \"%s\" is already in use." % self.vgname))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 1313, in execute
    v.execute(storage, ksdata, instClass)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 1647, in doKickstartStorage
    ksdata.volgroup.execute(storage, ksdata, instClass)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 393, in _doExecute
    doKickstartStorage(self.storage, self.data, self.instclass)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
KickstartValueError: The following problem occurred on line 32 of the kickstart file:

The volume group name "fedora_1" is already in use.


Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019\x20x86_64 ks=nfs:walnut.lan:/var/tmp/kickstart/ks-5.cfg BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19

Comment 1 Steve Tyler 2013-07-26 05:15:52 UTC
Created attachment 778664 [details]
File: anaconda-tb

Comment 2 Steve Tyler 2013-07-26 05:15:56 UTC
Created attachment 778665 [details]
File: anaconda.log

Comment 3 Steve Tyler 2013-07-26 05:16:00 UTC
Created attachment 778666 [details]
File: environ

Comment 4 Steve Tyler 2013-07-26 05:16:03 UTC
Created attachment 778667 [details]
File: ks.cfg

Comment 5 Steve Tyler 2013-07-26 05:16:08 UTC
Created attachment 778668 [details]
File: lsblk_output

Comment 6 Steve Tyler 2013-07-26 05:16:12 UTC
Created attachment 778669 [details]
File: nmcli_dev_list

Comment 7 Steve Tyler 2013-07-26 05:16:16 UTC
Created attachment 778670 [details]
File: os_info

Comment 8 Steve Tyler 2013-07-26 05:16:20 UTC
Created attachment 778671 [details]
File: program.log

Comment 9 Steve Tyler 2013-07-26 05:16:25 UTC
Created attachment 778672 [details]
File: storage.log

Comment 10 Steve Tyler 2013-07-26 05:16:28 UTC
Created attachment 778673 [details]
File: syslog

Comment 11 Steve Tyler 2013-07-26 05:16:32 UTC
Created attachment 778674 [details]
File: ifcfg.log

Comment 12 Steve Tyler 2013-07-26 05:16:36 UTC
Created attachment 778675 [details]
File: packaging.log

Comment 13 Steve Tyler 2013-07-26 05:23:01 UTC
The only change I made to the anaconda-generated kickstart file was to remove the '--fstype="lvmpv"' option:

...
#part pv.10 --fstype="lvmpv" --maxsize=11508 --ondisk=sda --size=11508
part pv.10 --maxsize=11508 --ondisk=sda --size=11508
...

Tested with:
$ qemu-kvm -m 4096 -hda f19-test-3.img -cdrom ~/xfr/fedora/F19/Fedora-19-x86_64-DVD.iso -vga std -boot menu=on

The kickstart file was served over NFS.

Comment 14 Steve Tyler 2013-07-26 05:28:15 UTC
After restoring the original "part" option, the same exception occurs:
...
part pv.10 --fstype="lvmpv" --maxsize=11508 --ondisk=sda --size=11508
#part pv.10 --maxsize=11508 --ondisk=sda --size=11508
...

Comment 15 Steve Tyler 2013-07-26 05:40:17 UTC
I forgot to initialize the disk image that had the original interactive install on it with VG fedora_1:
$ qemu-img create f19-test-3.img 32G

This shouldn't result in a bug reporting dialog being displayed, though ...

Comment 16 David Shea 2013-08-01 17:29:46 UTC
clearpart --all can be used to clear the partitions from a previous installation. Otherwise kickstart assumes that the kickstart file being used is valid for the system it's being used on, and errors such as this cause exceptions to be raised.

Comment 17 Steve Tyler 2013-08-01 17:46:36 UTC
OK, but as I said in Comment 15, this shouldn't result in a bug reporting dialog being displayed.

Of course, if you would prefer to receive bug reports for kickstart file errors, you are welcome to them. :-)

Reopening due to incorrect triage analysis.

Comment 18 Steve Tyler 2013-08-01 17:49:44 UTC
To put it more plainly:

The installer should display an alert with an informative error message, instead of a bug reporting dialog.


Note You need to log in before you can comment on or make changes to this bug.