Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 988622 - SELinux is preventing /usr/bin/chmod from 'setattr' accesses on the file atanno.
Summary: SELinux is preventing /usr/bin/chmod from 'setattr' accesses on the file atanno.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:37485aa90a77f4fcc916e9e23aa...
: 988623 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-26 02:11 UTC by Devon Janitz
Modified: 2013-07-26 16:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-26 06:46:52 UTC


Attachments (Terms of Use)

Description Devon Janitz 2013-07-26 02:11:27 UTC
Description of problem:
Joined Webex meeting and was wonder if this should be normal behavior due to bugs or something related to Webex itself.
SELinux is preventing /usr/bin/chmod from 'setattr' accesses on the file atanno.

*****  Plugin mozplugger (99.1 confidence) suggests  *************************

If you want to use the plugin package
Then you must turn off SELinux controls on the Firefox plugins.
Do
# setsebool unconfined_mozilla_plugin_transition 0

*****  Plugin catchall (1.81 confidence) suggests  ***************************

If you believe that chmod should be allowed setattr access on the atanno file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep chmod /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
                              0.c1023
Target Context                unconfined_u:object_r:user_home_t:s0
Target Objects                atanno [ file ]
Source                        chmod
Source Path                   /usr/bin/chmod
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           coreutils-8.21-11.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-65.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.9-302.fc19.x86_64 #1 SMP Sat
                              Jul 6 13:41:07 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-07-25 22:01:49 EDT
Last Seen                     2013-07-25 22:01:49 EDT
Local ID                      d8e649da-9dc6-4bba-a797-93d94cccba6e

Raw Audit Messages
type=AVC msg=audit(1374804109.471:630): avc:  denied  { setattr } for  pid=8256 comm="chmod" name="atanno" dev="dm-2" ino=20447812 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=file


type=SYSCALL msg=audit(1374804109.471:630): arch=x86_64 syscall=fchmodat success=yes exit=0 a0=ffffffffffffff9c a1=8aa0f0 a2=1fd a3=2b items=0 ppid=8118 pid=8256 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=1 tty=(none) comm=chmod exe=/usr/bin/chmod subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)

Hash: chmod,mozilla_plugin_t,user_home_t,file,setattr

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.9-302.fc19.x86_64
type:           libreport

Comment 1 Miroslav Grepl 2013-07-26 06:46:52 UTC
Does

# restorecon -R -v /home

fix your problem?

Comment 2 Miroslav Grepl 2013-07-26 06:47:47 UTC
*** Bug 988623 has been marked as a duplicate of this bug. ***

Comment 3 Devon Janitz 2013-07-26 12:21:52 UTC
That duplicate was after the rebuild to Fedora 19.  Will re-run # restorecon -R -v /home on the new build.
Thanks, Devon

Comment 4 Devon Janitz 2013-07-26 15:22:28 UTC
No changes I can tell.  Through 5 SELinux exeptions in all when joining a WebEx session.  I generally just setenforce 0 just before starting and setenforce 1 when done.
Devon

Comment 5 Devon Janitz 2013-07-26 15:24:03 UTC
Sorry, forgot to include this.  You can go to http://www.webex.com/test-meeting.html just to do a quick test and see if it all loads without actually joining a meeting.
Devon

Comment 6 Daniel Walsh 2013-07-26 16:41:27 UTC
Where is the atanno file?


Note You need to log in before you can comment on or make changes to this bug.