Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 988569 - [abrt] evolution-3.9.4-3.fc20: g_object_ref: Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)
Summary: [abrt] evolution-3.9.4-3.fc20: g_object_ref: Process /usr/bin/evolution was k...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:283df38c6072184447585926bd3...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-25 20:48 UTC by P. A. López-Valencia
Modified: 2013-09-30 08:29 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-26 17:03:35 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2013-07-25 20:48 UTC, P. A. López-Valencia
no flags Details
File: cgroup (deleted)
2013-07-25 20:48 UTC, P. A. López-Valencia
no flags Details
File: core_backtrace (deleted)
2013-07-25 20:48 UTC, P. A. López-Valencia
no flags Details
File: dso_list (deleted)
2013-07-25 20:48 UTC, P. A. López-Valencia
no flags Details
File: environ (deleted)
2013-07-25 20:48 UTC, P. A. López-Valencia
no flags Details
File: limits (deleted)
2013-07-25 20:49 UTC, P. A. López-Valencia
no flags Details
File: maps (deleted)
2013-07-25 20:49 UTC, P. A. López-Valencia
no flags Details
File: open_fds (deleted)
2013-07-25 20:49 UTC, P. A. López-Valencia
no flags Details
File: proc_pid_status (deleted)
2013-07-25 20:49 UTC, P. A. López-Valencia
no flags Details
File: var_log_messages (deleted)
2013-07-25 20:49 UTC, P. A. López-Valencia
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 704941 None None None Never

Description P. A. López-Valencia 2013-07-25 20:48:36 UTC
Description of problem:
This crash is related to EWS. When you set up a Office 365 account the last step is grabbing a list of server folders and copying the contents to the local disk. It crashes when the process starts.

Version-Release number of selected component:
evolution-3.9.4-3.fc20

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        evolution
crash_function: g_object_ref
executable:     /usr/bin/evolution
kernel:         3.11.0-0.rc2.git1.1.fc20.x86_64
runlevel:       unknown
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 g_object_ref at gobject.c:3054
 #1 g_weak_ref_get at gobject.c:4237
 #2 source_registry_source_notify_enabled_idle_cb at e-source-registry.c:582
 #7 e_source_registry_authenticate_sync at e-source-registry.c:2080
 #8 mail_session_authenticate_sync at e-mail-session.c:1600
 #9 camel_session_authenticate_sync at camel-session.c:1829
 #10 ews_connect_sync at camel-ews-store.c:653
 #11 service_connect_thread at camel-service.c:773
 #12 run_in_thread at gsimpleasyncresult.c:871
 #13 io_job_thread at gioscheduler.c:89

Comment 1 P. A. López-Valencia 2013-07-25 20:48:43 UTC
Created attachment 778526 [details]
File: backtrace

Comment 2 P. A. López-Valencia 2013-07-25 20:48:46 UTC
Created attachment 778527 [details]
File: cgroup

Comment 3 P. A. López-Valencia 2013-07-25 20:48:50 UTC
Created attachment 778528 [details]
File: core_backtrace

Comment 4 P. A. López-Valencia 2013-07-25 20:48:53 UTC
Created attachment 778529 [details]
File: dso_list

Comment 5 P. A. López-Valencia 2013-07-25 20:48:57 UTC
Created attachment 778530 [details]
File: environ

Comment 6 P. A. López-Valencia 2013-07-25 20:49:01 UTC
Created attachment 778531 [details]
File: limits

Comment 7 P. A. López-Valencia 2013-07-25 20:49:06 UTC
Created attachment 778532 [details]
File: maps

Comment 8 P. A. López-Valencia 2013-07-25 20:49:09 UTC
Created attachment 778533 [details]
File: open_fds

Comment 9 P. A. López-Valencia 2013-07-25 20:49:15 UTC
Created attachment 778534 [details]
File: proc_pid_status

Comment 10 P. A. López-Valencia 2013-07-25 20:49:19 UTC
Created attachment 778535 [details]
File: var_log_messages

Comment 11 Milan Crha 2013-07-26 17:03:35 UTC
Thanks for a bug report. I moved this upstream as [1]. Please see [1] for any further updates. If possible, please CC yourself there, in case upstream developers will have additional questions.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=704941

Comment 12 Milan Crha 2013-09-30 08:29:24 UTC
*** Bug 1013199 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.