Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 988469 - PRD34 - [RFE] vdsm does not recognize hot-plugged host interfaces
Summary: PRD34 - [RFE] vdsm does not recognize hot-plugged host interfaces
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.2.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: 3.4.0
Assignee: Dan Kenigsberg
QA Contact: Martin Pavlik
URL:
Whiteboard: network
Depends On: 999947 1240719
Blocks: 1058499 rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2013-07-25 16:13 UTC by Pratik Pravin Bandarkar
Modified: 2016-02-10 19:51 UTC (History)
10 users (show)

Fixed In Version: ovirt-3.4.0-alpha1
Doc Type: Enhancement
Doc Text:
VDSM now recognizes hot-plugged host interfaces.
Clone Of:
: 1058499 (view as bug list)
Environment:
Last Closed: 2014-06-09 13:25:10 UTC
oVirt Team: Network
Target Upstream Version:
nyechiel: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0504 normal SHIPPED_LIVE vdsm 3.4.0 bug fix and enhancement update 2014-06-09 17:21:35 UTC
oVirt gerrit 16227 None None None Never

Description Pratik Pravin Bandarkar 2013-07-25 16:13:18 UTC
Description of problem:
While system bootup, for some reason network interface was not detected. This issue got resolved after some time. ethtool <ethX> / ifconfig was showing the interface. But,  still "getVdsStats" output was not detecting the interface and as a result, vdsm was assuming the interface is not present on the system. As a workaround we manually restarted the "vdsmd" service. Then, it(vdsm) detected the interface. 


Version-Release number of selected component (if applicable):
vdsm

How reproducible:
100%

Steps to Reproduce:
1. 
2.  
3.

Actual results:
Even after network issue got resolved, "getVdsStats" output was not showing the interface and as a result, vdsm was assuming the interface is not present on the system. Manual intervention(service vdsmd restart) is needed to tell vdsm that, ethX interface is up. 

Expected results:
Once network issue is resolved and respective ethX interface detected by the system, changes should automatically reflect to vdsm. Manual intervention should not be there. 

Additional info:

Comment 1 Pratik Pravin Bandarkar 2013-07-25 16:27:53 UTC
I can reproduce the issue on nested virtulization:

1. start the hypervisor.
2. add NIC on the fly.
3. check if its detected by system from dmesg/ethtool ethX
4. Check if the same NIC gets displayed in:
---
 vdsClient -s 0 getVdsStats | egrep --color eth
---
it will not be there.

5. Now restart the vdsmd service:
6. Now you can see new interface from "vdsClient -s 0 getVdsStats" output.

Comment 2 psebek 2013-10-30 13:22:58 UTC
In my patch should be hotplugged devices visible in vdsStats after 10 seconds after devices are plugged.

Comment 11 Martin Pavlik 2014-02-24 16:09:12 UTC
set verified by mistake, putting back to ON_QA

Comment 12 errata-xmlrpc 2014-06-09 13:25:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0504.html


Note You need to log in before you can comment on or make changes to this bug.