Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 988399 - Package Installation fails with Transaction Check Error
Summary: Package Installation fails with Transaction Check Error
Keywords:
Status: CLOSED DUPLICATE of bug 988263
Alias: None
Product: Fedora
Classification: Fedora
Component: microcode_ctl
Version: 18
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Anton Arapov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-25 14:11 UTC by Tom Delany
Modified: 2014-06-18 08:03 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-26 00:18:51 UTC


Attachments (Terms of Use)

Description Tom Delany 2013-07-25 14:11:08 UTC
Description of problem:
Package installation fails with the following:
Transaction Check Error:
  file /lib/firmware/amd-ucode/microcode_amd.bin from install of microcode_ctl-2:2.0-2.fc18.x86_64 conflicts with file from package linux-firmware-20130724-0.1.git31f6b30.fc18.noarch
  file /lib/firmware/amd-ucode/microcode_amd_fam15h.bin from install of microcode_ctl-2:2.0-2.fc18.x86_64 conflicts with file from package linux-firmware-20130724-0.1.git31f6b30.fc18.noarch


Version-Release number of selected component (if applicable):
microcode_ctl-2.0-2.fc18.x86_64.rpm

How reproducible:
Always

Steps to Reproduce:
1. Attempt to install the pacakge.

Actual results:
Transaction Check Error:
  file /lib/firmware/amd-ucode/microcode_amd.bin from install of microcode_ctl-2:2.0-2.fc18.x86_64 conflicts with file from package linux-firmware-20130724-0.1.git31f6b30.fc18.noarch
  file /lib/firmware/amd-ucode/microcode_amd_fam15h.bin from install of microcode_ctl-2:2.0-2.fc18.x86_64 conflicts with file from package linux-firmware-20130724-0.1.git31f6b30.fc18.noarch

Expected results:
Success.

Additional info:

Comment 1 Egor Kuropatkin 2013-07-25 20:45:19 UTC
Same on Fedora 19 while trying to do 'yum upgrade':

Transaction check error:
  file /usr/lib/firmware/amd-ucode/microcode_amd.bin from install of linux-firmware-20130724-27.git31f6b30.fc19.noarch conflicts with file from package microcode_ctl-2:2.0-3.1.fc19.x86_64
  file /usr/lib/firmware/amd-ucode/microcode_amd_fam15h.bin from install of linux-firmware-20130724-27.git31f6b30.fc19.noarch conflicts with file from package microcode_ctl-2:2.0-3.1.fc19.x86_64

Comment 3 Josh Boyer 2013-07-26 00:18:51 UTC

*** This bug has been marked as a duplicate of bug 988263 ***


Note You need to log in before you can comment on or make changes to this bug.