Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 988343 - REST API root should not throw an exception, but offer a basic help
Summary: REST API root should not throw an exception, but offer a basic help
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss BPMS Platform 6
Classification: Retired
Component: Business Central
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
: ---
Assignee: Marco Rietveld
QA Contact: Marián Macik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-25 11:25 UTC by Jiri Svitak
Modified: 2016-09-20 05:06 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-07 13:31:03 UTC
Type: Feature Request


Attachments (Terms of Use)

Description Jiri Svitak 2013-07-25 11:25:19 UTC
When accessing an address
http://localhost:8080/business-central/rest
I get an ugly exception:

FAILURE /business-central/rest Could not find resource for relative : /business-central/rest of full path: http://localhost:8080/business-central/rest org.jboss.resteasy.spi.NotFoundException: Could not find resource for relative : /business-central/rest of full path: http://localhost:8080/business-central/rest at org.jboss.resteasy.core.registry.RootSegment.matchChildren(RootSegment.java:360) at
...

The root of the REST API and perhaps other REST API incomplete URLs should rather offer a basic navigation and list of available commands like in this wiki:
https://github.com/mrietveld/droolsjbpm-integration/wiki/Rest-API

BRMS 5.3.x business central REST API was able to offer a basic help, so this can be considered a regression.

Comment 1 Marco Rietveld 2013-07-25 15:48:19 UTC
Good idea, Jiri.

Comment 2 Marco Rietveld 2013-08-06 22:39:13 UTC
Setting to new, so that I can tell which bz's are modified ("ASSIGNED") and which aren't ("NEW").

Comment 3 Maciej Swiderski 2013-09-13 14:25:24 UTC
Marco, might be of use - I added something similar for execution server (lie-wb without UI) that for the root of the application will show simple table with REST operations

Here you can find the jsp page that shows the operations (it's built based on the rest wiki)
https://github.com/droolsjbpm/kie-wb-distributions/blob/master/kie-wb/kie-wb-webapp/src/main/webapp/rest-api.jsp

and here is how it binds to the web application 
https://github.com/droolsjbpm/kie-wb-distributions/blob/master/kie-wb/kie-wb-distribution-wars/src/main/eap6_1/WEB-INF/web-exec-server.xml#L76

Comment 4 Prakash Aradhya 2013-09-16 21:20:33 UTC
Internal Whiteboard: Beta Blocker → Blocker
Not critical for Beta, but need to address for GA

Comment 9 Jiri Svitak 2014-06-25 11:38:41 UTC
This issue still persists in BPMS 6.0.2.CR2.

As Maciej mentions, exec-server profile of business central already has such basic help screen for REST operations.

Comment 10 Marco Rietveld 2014-09-25 12:42:51 UTC
Work is being done to add swagger-ui to BPMS and BRMS.

Comment 11 Jiri Svitak 2014-10-01 12:47:17 UTC
I have checked with BPMS 6.1.0.DR3 and on page
http://localhost:8080/business-central
can be seen a help page listing basic REST API commands.

However the reported page
http://localhost:8080/business-central/rest
still shows the same error as in bug description.

New basic help screen in exec-server profile definitely improved the situation, but is there more work to be done? What is meant by swagger-ui?

Thanks,
Jiri

Comment 12 Marco Rietveld 2014-10-13 09:28:15 UTC
Unfortunately, the Swagger UI for both the kie-server and kie-remote REST interfaces did not make it into 6.2. 

For more info about Swagger, see: https://helloreverb.com/developers/swagger

Comment 15 Marco Rietveld 2015-12-07 13:31:03 UTC
Closing as not a bug. 

1. This is a feature request
2. We are working on other documentation solutions.


Note You need to log in before you can comment on or make changes to this bug.