Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 988174 - synaptics needs to do conditional scaling based on resolution
Summary: synaptics needs to do conditional scaling based on resolution
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-synaptics
Version: 6.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Peter Hutterer
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 893808 1012816 1034041
TreeView+ depends on / blocked
 
Reported: 2013-07-25 01:27 UTC by Peter Hutterer
Modified: 2018-12-03 19:25 UTC (History)
4 users (show)

Fixed In Version: xorg-x11-drv-synaptics-1.6.2-13.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-11-21 12:08:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1644 normal SHIPPED_LIVE xorg-x11-drv-synaptics bug fix update 2013-11-20 21:53:28 UTC

Description Peter Hutterer 2013-07-25 01:27:43 UTC
Description of problem:
Synaptics currently scales input coordinates based on the device resolution, with the simple calculation of y = y/(x:y ratio).

Bug 893808 requires scaling in the server to ensure consistent device behaviour for absolute devices in relative mode. For example, a circle on the tablet should ensure a circle on the screen. For that, the server needs to take the device resolution into account.

Touchpads are absolute devices in relative mode. For the server to scale appropriately, the synaptics driver cannot scale on its own. The fix proposed for 893808 bumps the minor input ABI and thus lets the driver detect whether it should scale or not. If not, the scaling is simply disabled at compile time.

Version-Release number of selected component (if applicable):
xorg-x11-drv-synaptics-1.6.2-11.el6.x86_64
xorg-x11-server-1.13.0-11.1.el6.x86_64

How reproducible:
See Bug 893808 for the original bug

Actual results:
If the synaptics driver isn't patch to stop scaling, the server fix will result in a double-scale of input coordinates, slowing down y movement to an unacceptably slow speed.


Expected results:
With a patched driver, changes in touchpad speed are minor enough to be undetectable.


Additional info:
http://cgit.freedesktop.org/xorg/xserver/commit/?id=21ea7ebb6a1ad56f3060747af0df235ca6ff27fa
http://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/commit/?id=0fb59b3487d57523a03f078a2061e2ea0cacbc7c

Comment 2 Peter Hutterer 2013-07-28 23:28:22 UTC
MODIFIED

xorg-x11-drv-synaptics-1.6.2-12.el6 is available in brew

Comment 3 Peter Hutterer 2013-07-30 05:16:01 UTC
MODIFIED

xorg-x11-drv-synaptics-1.6.2-13.el6 is available in brew

Comment 9 Michael Boisvert 2013-10-18 17:52:33 UTC
I tested this issue using a twinview setup, the intuos3, Intuos5 S and Intuos5 L. I laid a CD on the tablet's pad surface and used the center hole to trace a perfect circle in GIMP. Before the patch, doing this would draw an oval shape. With the new packages it creates a perfect circle meaning the speed is the same between X and Y.

Verified.

Comment 10 errata-xmlrpc 2013-11-21 12:08:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1644.html


Note You need to log in before you can comment on or make changes to this bug.