Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 987948 - upgrade to 3.3 fails in Fedora 19 when not using firewalld in 3.2
Summary: upgrade to 3.3 fails in Fedora 19 when not using firewalld in 3.2
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-installer
Version: 3.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.3
Assignee: Sandro Bonazzola
QA Contact:
URL:
Whiteboard: integration
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-24 12:56 UTC by Michal Skrivanek
Modified: 2014-10-13 11:07 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-31 08:02:47 UTC
oVirt Team: ---


Attachments (Terms of Use)
engine-upgrade log (deleted)
2013-07-24 12:58 UTC, Michal Skrivanek
no flags Details

Description Michal Skrivanek 2013-07-24 12:56:36 UTC
Description of problem:
upgrade from 3.2.2 to 3.3 beta fails at
File "/usr/share/ovirt-engine/setup/bin/../plugins/ovirt-engine-setup/legacy/firewalld.py", line 59, in _misc
AttributeError: type object 'NetEnv' has no attribute 'FIREWALLD_DISABLE_SERVICES'

How reproducible:
3.2 setup in latest F19, *not* using firewalld

Comment 1 Michal Skrivanek 2013-07-24 12:58:31 UTC
Created attachment 777765 [details]
engine-upgrade log

Comment 2 Sandro Bonazzola 2013-07-31 08:02:47 UTC
It seems that on your system otopi was not aligned to ovirt-engine.
FIREWALLD_DISABLE_SERVICES is an otopi constant in NetEnv, available from commit
c4c4c66f40534479cd70880dc4b42c8858d8be4e
I think that the otopi in beta was not aligned with ovirt-engine.
It works for me on nightly repository.
Can you check again on your system using nightly instead of beta?

Comment 3 Michal Skrivanek 2014-10-13 11:07:05 UTC
now works fine


Note You need to log in before you can comment on or make changes to this bug.