Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 987800 - (qemu) Disabling I/O throttling on 'drive-fdc0-0-0' due to synchronous I/O.
Summary: (qemu) Disabling I/O throttling on 'drive-fdc0-0-0' due to synchronous I/O.
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.5
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Fam Zheng
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-24 07:53 UTC by Sibiao Luo
Modified: 2013-09-05 15:35 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-05 15:35:03 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Sibiao Luo 2013-07-24 07:53:35 UTC
Description of problem:
boot guest with qemu i/o throttling(iops_wr=100) for floppy device, then the HMP monitor will prompt that 'Disabling I/O throttling on 'drive-fdc0-0-0' due to synchronous I/O.', this should not output in HMP monitor.

Version-Release number of selected component (if applicable):
host info:
2.6.32-400.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.379.el6.x86_64
seabios-0.6.1.2-28.el6.x86_64
guest info:
2.6.32-400.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.create a 1.44M floopy image.
# qemu-img create -f qcow2 floppy.vfd 1.44M
Formatting 'floppy.vfd', fmt=qcow2 size=1509949 encryption=off cluster_size=65536 
2.boot guest with qemu i/o throttling(iops_wr=100) for floppy device.
# /usr/libexec/qemu-kvm -S -M rhel6.5.0 -cpu SandyBridge -enable-kvm -m 4096 -smp 4,sockets=2,cores=2,threads=1 -no-kvm-pit-reinjection -name sluo -uuid 43425b70-86e5-4664-bf2c-3b76699b8bec -rtc base=localtime,clock=host,driftfix=slew -device virtio-serial-pci,id=virtio-serial0,max_ports=16,vectors=0,bus=pci.0,addr=0x3 -chardev socket,id=channel1,path=/tmp/helloworld1,server,nowait -device virtserialport,chardev=channel1,name=com.redhat.rhevm.vdsm.1,bus=virtio-serial0.0,id=port1,nr=1 -chardev socket,id=channel2,path=/tmp/helloworld2,server,nowait -device virtserialport,chardev=channel2,name=com.redhat.rhevm.vdsm.2,bus=virtio-serial0.0,id=port2,nr=2 -drive file=/home/RHEL6.5-20130721.n.0_6.5_Server_x86_64.qcow2,if=none,id=drive-system-disk,format=qcow2,cache=none,aio=native,werror=stop,rerror=stop,serial="QEMU-DISK1" -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x4,drive=drive-system-disk,id=system-disk,bootindex=1 -device virtio-balloon-pci,id=ballooning,bus=pci.0,addr=0x5 -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -netdev tap,id=hostnet0,vhost=off,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet0,id=virtio-net-pci0,mac=2C:41:38:B6:40:21,bus=pci.0,addr=0x6,bootindex=2 -k en-us -boot menu=on -qmp tcp:0:4444,server,nowait -serial unix:/tmp/ttyS0,server,nowait -vnc :1 -spice port=5931,disable-ticketing -monitor stdio -drive file=/home/floppy.vfd,if=none,id=drive-fdc0-0-0,format=qcow2,cache=none,iops_wr=100 -global isa-fdc.driveA=drive-fdc0-0-0
(qemu) info block
drive-system-disk: removable=0 io-status=ok file=/home/RHEL6.5-20130721.n.0_6.5_Server_x86_64.qcow2 ro=0 drv=qcow2 encrypted=0 bps=0 bps_rd=0 bps_wr=0 iops=0 iops_rd=0 iops_wr=0
drive-fdc0-0-0: removable=1 locked=0 tray-open=0 file=/home/floppy.vfd ro=0 drv=qcow2 encrypted=0 bps=0 bps_rd=0 bps_wr=0 iops=0 iops_rd=0 iops_wr=100
3.run sequentialwrite in guest.
# modproble floppy
# fio --filename=/dev/fd0 --direct=1 --rw=write --bs=1K --size=1M --name=test --iodepth=1 --ioengine=libaio

Actual results:
after step 2, the HMP monitor will prompt that 'Disabling I/O throttling on 'drive-fdc0-0-0' due to synchronous I/O.'
after step 3, it work well as expected.

Expected results:
No 'Disabling I/O throttling on 'drive-fdc0-0-0' due to synchronous I/O.' output in HMP monitor.

Additional info:

Comment 1 Sibiao Luo 2013-07-24 07:56:29 UTC
Tried it in rhel7 host that has no such issue.

IIRC,  qemu i/o throtting has support all block interface device: IDE(ide disk,ide cdrom), virtio_blk, virtio-scsi(crdrom, block), usb storage, Floppy...

Best Regards,
sluo

Comment 2 Sibiao Luo 2013-07-24 07:58:55 UTC
(In reply to Sibiao Luo from comment #0)
> Actual results:
> after step 2, the HMP monitor will prompt that 'Disabling I/O throttling on
> 'drive-fdc0-0-0' due to synchronous I/O.'
QEMU 0.12.1 monitor - type 'help' for more information
(qemu) c
(qemu) main_channel_link: add main channel client
main_channel_handle_parsed: net test: latency 65.147000 ms, bitrate 6895622895 bps (6576.178451 Mbps)
inputs_connect: inputs channel client create
red_dispatcher_set_cursor_peer: 

(qemu) Disabling I/O throttling on 'drive-fdc0-0-0' due to synchronous I/O.

(qemu) info block
drive-system-disk: removable=0 io-status=ok file=/home/RHEL6.5-20130721.n.0_6.5_Server_x86_64.qcow2 ro=0 drv=qcow2 encrypted=0 bps=0 bps_rd=0 bps_wr=0 iops=0 iops_rd=0 iops_wr=0
drive-fdc0-0-0: removable=1 locked=0 tray-open=0 file=/home/floppy.vfd ro=0 drv=qcow2 encrypted=0 bps=0 bps_rd=0 bps_wr=0 iops=0 iops_rd=0 iops_wr=100
...
(qemu) info status 
VM status: running

Comment 3 Kevin Wolf 2013-07-24 10:00:27 UTC
(In reply to Sibiao Luo from comment #1)
> Tried it in rhel7 host that has no such issue.
> 
> IIRC,  qemu i/o throtting has support all block interface device: IDE(ide
> disk,ide cdrom), virtio_blk, virtio-scsi(crdrom, block), usb storage,
> Floppy...

Throttling isn't supported for floppy even in the latest upstream releases.
RHEL 7 should actually have the same behaviour.

Comment 4 Sibiao Luo 2013-07-25 01:35:07 UTC
(In reply to Kevin Wolf from comment #3)
> (In reply to Sibiao Luo from comment #1)
> > Tried it in rhel7 host that has no such issue.
> > 
> > IIRC,  qemu i/o throtting has support all block interface device: IDE(ide
> > disk,ide cdrom), virtio_blk, virtio-scsi(crdrom, block), usb storage,
> > Floppy...
> 
> Throttling isn't supported for floppy even in the latest upstream releases.
> RHEL 7 should actually have the same behaviour.

ok, good catch, but according to my testing that rhel7 did not meet this issue.

Comment 6 Ademar Reis 2013-09-05 15:35:03 UTC
We're OK with RHEL7 (comment #4) and this is a corner case for something that's really rare.

Closing as WONTFIX in RHEL6.


Note You need to log in before you can comment on or make changes to this bug.