Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 987735 - error: unpacking of archive failed on file /usr/share/man/de/man8/fatlabel.8.gz;51e5abf4: cpio: open failed - No such file or directory
Summary: error: unpacking of archive failed on file /usr/share/man/de/man8/fatlabel.8....
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dosfstools
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Škarvada
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 984709 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-24 03:22 UTC by Steve Tyler
Modified: 2013-08-02 20:36 UTC (History)
3 users (show)

Fixed In Version: dosfstools-3.0.22-2.fc18
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-28 01:03:35 UTC


Attachments (Terms of Use)

Description Steve Tyler 2013-07-24 03:22:24 UTC
Description of problem:
Bug 984709 describes a kickstart install failure that ends with this error message:

Installing dosfstools-3.0.20-2.fc18.x86_64 (579/3432)
error: unpacking of archive failed on file /usr/share/man/de/man8/fatlabel.8.gz;51e5abf4: cpio: open failed - No such file or directory

See Bug 984709, Comment 13.

dosfstools and filesystem both own some man page directories:

$ rpm -qf /usr/share/man/de
dosfstools-3.0.20-3.fc19.x86_64
filesystem-3.2-13.fc19.x86_64

$ rpm -qf /usr/share/man/de/man8
dosfstools-3.0.20-3.fc19.x86_64
filesystem-3.2-13.fc19.x86_64

$ rpm -qf /usr/share/man/man8
dosfstools-3.0.20-3.fc19.x86_64
filesystem-3.2-13.fc19.x86_64

$ rpm -qf /usr/share/man/
filesystem-3.2-13.fc19.x86_64

$ rpm -qf /usr/share/man/it
filesystem-3.2-13.fc19.x86_64

$ rpm -qf /usr/share/man/fr
filesystem-3.2-13.fc19.x86_64

Version-Release number of selected component (if applicable):
dosfstools-3.0.20-2.fc18.x86_64

How reproducible:
Always, with the same kickstart file.
Depends on the kickstart file.
See attachments to Bug 984709.

A minimal kickstart install, with only dosfstools specified, succeeds.

The problem does not seem to occur with F19, although the above rpm reports show that dosfstools and filesystem both own the de man page directories.

Steps to Reproduce:
1. Do a kickstart install using the kickstart files attached to Bug 984709.

Actual results:
Installing dosfstools-3.0.20-2.fc18.x86_64 (579/3432)
error: unpacking of archive failed on file /usr/share/man/de/man8/fatlabel.8.gz;51e5abf4: cpio: open failed - No such file or directory

Examination of the install target shows that /usr/share/man/de does not exist.

Expected results:
German man pages install successfully.

Additional info:

Packaged DE man pages
http://pkgs.fedoraproject.org/cgit/dosfstools.git/commit/?h=f18&id=ca784a08f2f73c1d91dc6df48001f4262cb5f19b

Comment 1 Jaroslav Škarvada 2013-07-24 08:09:53 UTC
Thanks for spotting this.

Comment 2 Fedora Update System 2013-07-24 08:29:54 UTC
dosfstools-3.0.22-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/dosfstools-3.0.22-2.fc19

Comment 3 Fedora Update System 2013-07-24 08:30:35 UTC
dosfstools-3.0.22-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/dosfstools-3.0.22-2.fc18

Comment 4 Steve Tyler 2013-07-24 09:37:21 UTC
Thanks for the quick fix.

Comment 5 Fedora Update System 2013-07-25 00:44:43 UTC
Package dosfstools-3.0.22-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dosfstools-3.0.22-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13562/dosfstools-3.0.22-2.fc18
then log in and leave karma (feedback).

Comment 6 Steve Tyler 2013-07-25 17:42:53 UTC
FYI, dosfstools-3.0.22-2.fc18 appears to have fixed the kickstart install failures:
Bug 984709, Comment 38
Bug 984709, Comment 40

Comment 7 Fedora Update System 2013-07-28 01:03:35 UTC
dosfstools-3.0.22-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2013-07-28 01:07:18 UTC
dosfstools-3.0.22-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 David Shea 2013-08-02 20:36:44 UTC
*** Bug 984709 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.