Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 987601 - SELinux is preventing systemd-tmpfile from 'relabelto' accesses on the chr_file fuse.
Summary: SELinux is preventing systemd-tmpfile from 'relabelto' accesses on the chr_fi...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:043fd6db0407739d9eb6f8544c6...
: 987600 987604 987605 987607 987608 987611 987613 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-23 18:39 UTC by Nicolas Mailhot
Modified: 2013-07-24 21:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-24 21:43:53 UTC


Attachments (Terms of Use)

Description Nicolas Mailhot 2013-07-23 18:39:30 UTC
Description of problem:
SELinux is preventing systemd-tmpfile from 'relabelto' accesses on the chr_file fuse.

*****  Plugin associate (99.5 confidence) suggests  **************************

If vous souhaitez modifier l'étiquette de fuse en fuse_device_t,  ce qui est interdit car pas un type de fichier valide.
Then vous devez choisir une étiquette de fichier valide.
Do
select a valid file type.  List valid file labels by executing: 
# seinfo -afile_type -x

*****  Plugin catchall (1.49 confidence) suggests  ***************************

If vous pensez que systemd-tmpfile devrait être autorisé à accéder relabelto sur fuse chr_file par défaut.
Then vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Do
autoriser cet accès pour le moment en exécutant :
# grep systemd-tmpfile /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:systemd_tmpfiles_t:s0
Target Context                system_u:object_r:fuse_device_t:s0
Target Objects                fuse [ chr_file ]
Source                        systemd-tmpfile
Source Path                   systemd-tmpfile
Port                          <Inconnu>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-66.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.11.0-0.rc0.git3.1.fc20.x86_64 #1
                              SMP Tue Jul 9 21:34:37 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-07-23 20:34:45 CEST
Last Seen                     2013-07-23 20:34:45 CEST
Local ID                      06c9a564-5dd5-4a43-a459-7ef9fd48e982

Raw Audit Messages
type=AVC msg=audit(1374604485.339:62): avc:  denied  { relabelto } for  pid=574 comm="systemd-tmpfile" name="fuse" dev="devtmpfs" ino=9968 scontext=system_u:system_r:systemd_tmpfiles_t:s0 tcontext=system_u:object_r:fuse_device_t:s0 tclass=chr_file


Hash: systemd-tmpfile,systemd_tmpfiles_t,fuse_device_t,chr_file,relabelto

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.11.0-0.rc0.git3.1.fc20.x86_64
type:           libreport

Comment 1 Miroslav Grepl 2013-07-24 08:39:14 UTC
*** Bug 987600 has been marked as a duplicate of this bug. ***

Comment 2 Miroslav Grepl 2013-07-24 08:39:25 UTC
*** Bug 987604 has been marked as a duplicate of this bug. ***

Comment 3 Miroslav Grepl 2013-07-24 08:39:31 UTC
*** Bug 987605 has been marked as a duplicate of this bug. ***

Comment 4 Miroslav Grepl 2013-07-24 08:39:35 UTC
*** Bug 987607 has been marked as a duplicate of this bug. ***

Comment 5 Miroslav Grepl 2013-07-24 08:39:39 UTC
*** Bug 987608 has been marked as a duplicate of this bug. ***

Comment 6 Miroslav Grepl 2013-07-24 08:39:51 UTC
*** Bug 987611 has been marked as a duplicate of this bug. ***

Comment 7 Miroslav Grepl 2013-07-24 08:40:01 UTC
*** Bug 987613 has been marked as a duplicate of this bug. ***

Comment 8 Daniel Walsh 2013-07-24 21:43:53 UTC
Fixed in selinux-policy-3.12.1-67.fc20.noarch


Note You need to log in before you can comment on or make changes to this bug.