Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 987551 - Icon is only updated once per subscription-manager-gui run
Summary: Icon is only updated once per subscription-manager-gui run
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager
Version: 5.10
Hardware: All
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Carter Kozak
QA Contact: IDM QE LIST
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel510
TreeView+ depends on / blocked
 
Reported: 2013-07-23 15:56 UTC by Carter Kozak
Modified: 2014-09-15 00:08 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Clone Of:
Environment:
Last Closed: 2013-09-30 23:14:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1332 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2013-09-30 22:49:24 UTC

Description Carter Kozak 2013-07-23 15:56:26 UTC
Description of problem:
Icon is only updated once per subscription-manager-gui run

Version-Release number of selected component (if applicable):
# subman version
server type: This system is currently not registered.
subscription management server: 0.8.17-1
subscription-manager: 1.8.13-1.git.34.3855d08.fc19
python-rhsm: 1.8.14-1.git.1.1ba97bb.fc19

How reproducible:
4/4

Steps to Reproduce:
run subscription-manager-gui
the icon will update right away
Nothing else will update 

Actual results:
the icon doesn't update again

Expected results:
The icon should update when compliance changes

Additional info:
fix is on the way

Comment 1 RHEL Product and Program Management 2013-07-23 18:49:32 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.

Comment 2 Carter Kozak 2013-07-23 20:20:04 UTC
commit 0534bbbe05502b4e183a34a2b7fa0f19bbd84785
Author: ckozak <ckozak@redhat.com>
Date:   Thu Jul 11 14:56:19 2013 -0400

    987551: correctly reconnect to rhsmd daemon
    
    Cuts down on api calls from the dbus daemon by
    sending the calculated compliance value from the client.

Comment 6 Rehana 2013-08-07 06:19:20 UTC
Retested with below steps
Launch sub-man gui , and executed test in the below sequence
1. no subscription for the product
2. partial subscription for the product
3. from partial to full subscription for the product
4. full subscription to unsubscribe the subscription

Observed that, in all above changes on the subscriptions/product were updated on rhsmicon immediatly 

hence moving this bug to verified.

on 

subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.8.19-1
subscription-manager: 1.8.16-1.el5
python-rhsm: 1.8.16-1.el5

Comment 8 errata-xmlrpc 2013-09-30 23:14:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1332.html


Note You need to log in before you can comment on or make changes to this bug.