Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 987436 - ip6tables doesn't drop/reject IPv6 tcp packet
Summary: ip6tables doesn't drop/reject IPv6 tcp packet
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: iptables
Version: 5.10
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Thomas Woerner
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-23 11:33 UTC by Hangbin Liu
Modified: 2013-07-23 11:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-23 11:50:46 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Hangbin Liu 2013-07-23 11:33:53 UTC
Description of problem:
ip6tables doesn't drop/reject IPv6 tcp packet

Version-Release number of selected component (if applicable):
# rpm -qa | grep iptables
iptables-1.3.5-9.2.el5_8
iptables-ipv6-1.3.5-9.2.el5_8
# uname -ri
2.6.18-365.el5 x86_64

How reproducible:
every time

Steps to Reproduce:
1. # ip6tables -A INPUT -m state --state NEW -j REJECT
2. # ssh -6 ::1
3.

Actual results:
# ssh -6 ::1
root@::1's password:

Expected results:
# ssh -6 ::1
ssh: connect to host ::1 port 22: Connection refused

Additional info:

Comment 1 RHEL Product and Program Management 2013-07-23 11:38:28 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 2 Thomas Woerner 2013-07-23 11:50:46 UTC
Please have a look at: https://access.redhat.com/site/solutions/28381
and https://bugzilla.redhat.com/show_bug.cgi?id=243739


Note You need to log in before you can comment on or make changes to this bug.