Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 987280 - The min number of gears can be set to be bigger than max number.
Summary: The min number of gears can be set to be bigger than max number.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Pod
Version: 2.x
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Abhishek Gupta
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-23 07:15 UTC by Yujie Zhang
Modified: 2015-05-15 00:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-08-07 22:55:53 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Yujie Zhang 2013-07-23 07:15:44 UTC
Description of problem:

Set 2 to be minmum gear numbers of app and 1 to be maxmum gear number, and it can be saved, it should not allow to set min number bigger than max number.

Version-Release number of selected component (if applicable):
devenv_3540

How reproducible:
always

Steps to Reproduce:
1.Set 2 to be minmum gear number of app from website
2.Set 1 to be maxmum gear number of app from website
3.Click the "Save" button

Actual results:

It can be saved successfully, and restapi result like the following:

<scales-from>2</scales-from>
<scales-to>1</scales-to>
<base-gear-storage>1</base-gear-storage>

Expected results:

It should not allow to set min gear number bigger than max gear number.

Additional info:

Comment 1 Abhishek Gupta 2013-07-23 18:46:14 UTC
Could not reproduce on the latest devenv. The UI automatically switches the min and max values assuming it to be a user input error. If the REST API call is made with the invalid values, an error message is returned.

Comment 2 Yujie Zhang 2013-07-24 03:36:07 UTC
Tested on devenv_3544, can not reproduce this issue, UI will switch the min and max when they are invalid, so verify this bug, thanks.


Note You need to log in before you can comment on or make changes to this bug.