Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 987254 - SELinux is preventing /usr/sbin/abrtd from 'create' accesses on the lnk_file .lock.
Summary: SELinux is preventing /usr/sbin/abrtd from 'create' accesses on the lnk_file ...
Keywords:
Status: CLOSED DUPLICATE of bug 987247
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 18
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:76f46a02b2f16fb8c4eb0990940...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-23 05:34 UTC by Ricardo Cantu
Modified: 2013-07-23 12:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-23 12:04:25 UTC


Attachments (Terms of Use)

Description Ricardo Cantu 2013-07-23 05:34:01 UTC
Description of problem:
SELinux is preventing /usr/sbin/abrtd from 'create' accesses on the lnk_file .lock.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that abrtd should be allowed create access on the .lock lnk_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep abrtd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:abrt_t:s0-s0:c0.c1023
Target Context                system_u:object_r:initrc_tmp_t:s0
Target Objects                .lock [ lnk_file ]
Source                        abrtd
Source Path                   /usr/sbin/abrtd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           abrt-2.1.5-1.fc18.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-97.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.10-200.fc18.x86_64 #1 SMP Sun
                              Jul 14 01:36:53 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-07-22 23:03:59 MDT
Last Seen                     2013-07-22 23:03:59 MDT
Local ID                      643ce410-0dce-46a3-a46c-733bb1adc232

Raw Audit Messages
type=AVC msg=audit(1374555839.710:21): avc:  denied  { create } for  pid=464 comm="abrtd" name=".lock" scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=lnk_file


type=SYSCALL msg=audit(1374555839.710:21): arch=x86_64 syscall=symlink success=no exit=EACCES a0=7fff103ecd30 a1=7fff103eccb0 a2=383133 a3=7fff103eca40 items=0 ppid=1 pid=464 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=abrtd exe=/usr/sbin/abrtd subj=system_u:system_r:abrt_t:s0-s0:c0.c1023 key=(null)

Hash: abrtd,abrt_t,initrc_tmp_t,lnk_file,create

audit2allow

#============= abrt_t ==============
allow abrt_t initrc_tmp_t:lnk_file create;

audit2allow -R
require {
	type initrc_tmp_t;
	type abrt_t;
	class lnk_file create;
}

#============= abrt_t ==============
allow abrt_t initrc_tmp_t:lnk_file create;


Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.10-200.fc18.x86_64
type:           libreport

Comment 1 Miroslav Grepl 2013-07-23 12:04:25 UTC

*** This bug has been marked as a duplicate of bug 987247 ***


Note You need to log in before you can comment on or make changes to this bug.