Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 987247 - SELinux is preventing /usr/sbin/abrtd from 'add_name' accesses on the directory .lock.
Summary: SELinux is preventing /usr/sbin/abrtd from 'add_name' accesses on the directo...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 18
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:acc58bf53cca06b756ab70c3d87...
: 987254 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-23 05:02 UTC by Ricardo Cantu
Modified: 2013-07-23 12:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-23 12:10:41 UTC


Attachments (Terms of Use)

Description Ricardo Cantu 2013-07-23 05:02:56 UTC
Description of problem:
yum -y update
SELinux is preventing /usr/sbin/abrtd from 'add_name' accesses on the directory .lock.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that abrtd should be allowed add_name access on the .lock directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep abrtd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:abrt_t:s0-s0:c0.c1023
Target Context                system_u:object_r:initrc_tmp_t:s0
Target Objects                .lock [ dir ]
Source                        abrtd
Source Path                   /usr/sbin/abrtd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           abrt-2.1.5-1.fc18.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-97.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.2-200.fc18.x86_64 #1 SMP Mon
                              May 13 13:59:47 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-07-22 22:59:16 MDT
Last Seen                     2013-07-22 22:59:16 MDT
Local ID                      79a7a5e2-ff4c-4557-9425-8d56812fc0d5

Raw Audit Messages
type=AVC msg=audit(1374555556.312:1156): avc:  denied  { add_name } for  pid=26793 comm="abrtd" name=".lock" scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=dir


type=SYSCALL msg=audit(1374555556.312:1156): arch=x86_64 syscall=symlink success=no exit=EACCES a0=7fff39ff7120 a1=7fff39ff70a0 a2=383133 a3=7fff39ff6e30 items=0 ppid=1 pid=26793 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=abrtd exe=/usr/sbin/abrtd subj=system_u:system_r:abrt_t:s0-s0:c0.c1023 key=(null)

Hash: abrtd,abrt_t,initrc_tmp_t,dir,add_name

audit2allow

#============= abrt_t ==============
allow abrt_t initrc_tmp_t:dir add_name;

audit2allow -R
require {
	type initrc_tmp_t;
	type abrt_t;
	class dir add_name;
}

#============= abrt_t ==============
allow abrt_t initrc_tmp_t:dir add_name;


Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.2-200.fc18.x86_64
type:           libreport

Comment 1 Miroslav Grepl 2013-07-23 12:04:25 UTC
*** Bug 987254 has been marked as a duplicate of this bug. ***

Comment 2 Miroslav Grepl 2013-07-23 12:10:41 UTC
Please execute

# restorecon -R -v /var/tmp/abrt


Note You need to log in before you can comment on or make changes to this bug.