Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 987 - Mangles chat script containing #
Summary: Mangles chat script containing #
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: linuxconf
Version: 5.2
Hardware: alpha
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
: 2668 7715 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-01-28 15:09 UTC by wrossberg
Modified: 2008-05-01 15:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-03-29 20:17:06 UTC


Attachments (Terms of Use)

Description wrossberg 1999-01-28 15:09:39 UTC
Linuxconf fails to handle chat scripts containing # in
response strings. Comments in chat scripts are marked by a #
in the first position of a line. It is valid to include a #
inside strings. Linuxconf seems to consider a # as a comment
marker regardless of its context. It also removes
significant trailing whitespace at the end of strings, even
when enclosed in single quotes (').

Comment 1 wrossberg 1999-01-28 15:13:59 UTC
The problem is manifest in the configuration of PPP devices.

Comment 2 David Lawrence 1999-04-08 18:33:59 UTC
Could you send us a sample chat-ppp0 script where this is failing for
you (minus user account info). Thanks.

Comment 3 Michael K. Johnson 1999-04-10 01:44:59 UTC
Added Jacques to CC list

Comment 4 wrossberg 1999-04-12 14:30:59 UTC
Requested chat script example with the corresponding damaged version
produced by linuxconf were sent to dkl@redhat.com on 12-APR-1999.

Comment 5 Jay Turner 1999-06-29 17:33:59 UTC
This issue has been forwarded to a developer for further action.

Comment 6 Michael K. Johnson 1999-07-13 16:22:59 UTC
Jacques, have you had a chance to look into this yet?

Comment 7 Michael K. Johnson 1999-08-28 19:09:59 UTC
Jacques, can you look at this, please?

Comment 8 Michael K. Johnson 1999-08-28 19:32:59 UTC
*** Bug 2668 has been marked as a duplicate of this bug. ***

A PAP password entered with gnome-linuxconf that contains an
octothorpe '#' character appears to cause pppd to truncate
the password, causing logins to fail. '#' (and maybe other
characters) must be backslash quoted in the
/etc/ppp/pap-secrets file.

------- Additional Comments From notting@redhat.com  08/27/99 19:07 -------


*** Bug 4753 has been marked as a duplicate of this bug. ***

I am setting up a system that uses PPP to dial out to a
server.  To dial out through the PBX at that location, you
must dial a "#" first.  This character is a comment
character to the "chat" program if it is at the beginning of
a line, but not anywhere else on the line.  However,
linuxconf cannot handle the "#" in the dial string.  If I
put it in and save the interface and then go back in to the
interface configuration screen, the dial number is empty
(like linuxconf sees "#" as a comment anywhere and tosses
it).  It looks like linuxconf does not even save the dial
number; if I go in and manually edit
/etc/sysconfig/network-scripts/chat-ppp0, it just has a line
like:

'OK' 'ATDT'

and I have to manually put in the number to dial.  If I go
back in to linuxconf and do anything to the interface I have
to again manually put the number in.

Comment 9 Michael K. Johnson 1999-12-15 16:00:59 UTC
*** Bug 7715 has been marked as a duplicate of this bug. ***

Comment 10 Michael K. Johnson 1999-12-16 17:35:59 UTC
Jacques' partial fix (# taken literally) is in linuxconf-1.10r16-3,
which will be in the next RawHide release.  That does not address
the literal whitespace problem.

Comment 11 Michael K. Johnson 1999-12-16 17:36:59 UTC
Oops, make that linuxconf-1.16r10-3, sorry for the version typo.

Comment 12 Nalin Dahyabhai 2000-03-29 20:16:59 UTC
As of linuxconf 1.17r7, all chat strings are single-quoted by default, but a
single quote within a string needs to be manually escaped. This will be fixed in
linuxconf-1.17r7-2 in Raw Hide.


Note You need to log in before you can comment on or make changes to this bug.