Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 986851 - ipa-client-install fails when dbus is updated without restarting it
Summary: ipa-client-install fails when dbus is updated without restarting it
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dbus
Version: 5.9
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Richard Hughes
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-22 08:58 UTC by Eduardo Minguez
Modified: 2018-12-05 16:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-02 13:03:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 906293 None None None Never

Description Eduardo Minguez 2013-07-22 08:58:36 UTC
Description of problem:
RHEL5.2 + RHEL5.9 ipa-client packages fails running ipa-client-install:
...
root        : DEBUG    args=/sbin/service messagebus start 
root        : DEBUG    stdout=Starting system message bus: 
root        : DEBUG    stderr=
root        : DEBUG    args=/sbin/service certmonger restart 
root        : DEBUG    stdout=Stopping certmonger:         [FAILED]
Starting certmonger:                                       [FAILED]
root        : DEBUG    stderr=Error connecting to D-Bus.
Insufficient access.  Please retry operation as root.
root        : ERROR    certmonger failed to restart: Command '/sbin/service certmonger restart ' returned non-zero exit status 1
root        : DEBUG    args=/sbin/service certmonger stop 
root        : DEBUG    stdout=
root        : DEBUG    stderr=
root        : DEBUG    args=/sbin/service certmonger restart 
root        : DEBUG    stdout=Stopping certmonger:         [FAILED]
Starting certmonger:                                       [FAILED]
root        : DEBUG    stderr=Error connecting to D-Bus.
Insufficient access.  Please retry operation as root.
Failed to start the certmonger daemon
Automatic certificate management will not be available
root        : ERROR    certmonger failed to restart: Command '/sbin/service certmonger restart ' returned non-zero exit status 1
root        : DEBUG    args=/sbin/chkconfig certmonger on
root        : DEBUG    stdout=
root        : DEBUG    stderr=
...

Version-Release number of selected component (if applicable):
ipa-client-2.1.3-5.el5_9.2.x86_64.rpm

How reproducible:
Try to enroll a RHEL5.2 client with RHEL5.9 ipa-client packages

Steps to Reproduce:
1. Install RHEL5.2
2. Install ipa-client packages from RHEL5.9
3. Run ipa-client-install

Actual results:
Cert installation fails:
...
root        : DEBUG    args=/sbin/service messagebus start 
root        : DEBUG    stdout=Starting system message bus: 
root        : DEBUG    stderr=
root        : DEBUG    args=/sbin/service certmonger restart 
root        : DEBUG    stdout=Stopping certmonger:         [FAILED]
Starting certmonger:                                       [FAILED]
root        : DEBUG    stderr=Error connecting to D-Bus.
Insufficient access.  Please retry operation as root.
root        : ERROR    certmonger failed to restart: Command '/sbin/service certmonger restart ' returned non-zero exit status 1
root        : DEBUG    args=/sbin/service certmonger stop 
root        : DEBUG    stdout=
root        : DEBUG    stderr=
root        : DEBUG    args=/sbin/service certmonger restart 
root        : DEBUG    stdout=Stopping certmonger:         [FAILED]
Starting certmonger:                                       [FAILED]
root        : DEBUG    stderr=Error connecting to D-Bus.
Insufficient access.  Please retry operation as root.
Failed to start the certmonger daemon
Automatic certificate management will not be available
root        : ERROR    certmonger failed to restart: Command '/sbin/service certmonger restart ' returned non-zero exit status 1
root        : DEBUG    args=/sbin/chkconfig certmonger on
root        : DEBUG    stdout=
root        : DEBUG    stderr=
...

Expected results:
Cert installation correctly

Additional info:
ipa-client dependencies update dbus package, but because it's not restarted, the installation fails.
Maybe the solution is modify the installation procedure by performing a messagebus restart instead a start

Comment 1 Martin Kosek 2013-07-22 11:05:14 UTC
It seems to me that the restart should be rather performed by dbus itself during the upgrade procedure. ipa-client as a dbus consumer just makes sure that dbus is started as it is needed by certmonger. But I do not think that we should interfere with dbus upgrades.

Moving to dbus component to evaluate this issue.

Comment 2 RHEL Product and Program Management 2014-03-07 13:34:35 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 3 RHEL Product and Program Management 2014-06-02 13:03:06 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).


Note You need to log in before you can comment on or make changes to this bug.