Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 986807 - [abrt] kdelibs-4.10.5-1.fc19: KScreen::Mode::size: Process /usr/bin/kded4 was killed by signal 11 (SIGSEGV)
Summary: [abrt] kdelibs-4.10.5-1.fc19: KScreen::Mode::size: Process /usr/bin/kded4 was...
Keywords:
Status: CLOSED DUPLICATE of bug 981624
Alias: None
Product: Fedora
Classification: Fedora
Component: kscreen
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Daniel Vrátil
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:2de04da3429e9c0608c89b3630f...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-22 07:12 UTC by dte.linux
Modified: 2015-11-02 01:37 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-26 08:55:31 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2013-07-22 07:12 UTC, dte.linux
no flags Details
File: cgroup (deleted)
2013-07-22 07:12 UTC, dte.linux
no flags Details
File: core_backtrace (deleted)
2013-07-22 07:12 UTC, dte.linux
no flags Details
File: dso_list (deleted)
2013-07-22 07:12 UTC, dte.linux
no flags Details
File: environ (deleted)
2013-07-22 07:12 UTC, dte.linux
no flags Details
File: limits (deleted)
2013-07-22 07:12 UTC, dte.linux
no flags Details
File: maps (deleted)
2013-07-22 07:13 UTC, dte.linux
no flags Details
File: open_fds (deleted)
2013-07-22 07:13 UTC, dte.linux
no flags Details
File: proc_pid_status (deleted)
2013-07-22 07:13 UTC, dte.linux
no flags Details
File: var_log_messages (deleted)
2013-07-22 07:13 UTC, dte.linux
no flags Details

Description dte.linux 2013-07-22 07:12:31 UTC
Version-Release number of selected component:
kdelibs-4.10.5-1.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        /usr/bin/kded4 --nocrashhandler
crash_function: KScreen::Mode::size
executable:     /usr/bin/kded4
kernel:         3.9.9-302.fc19.x86_64
runlevel:       N 5
uid:            1000
xsession_errors: 

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 KScreen::Mode::size at /usr/src/debug/libkscreen-1.0/src/mode.cpp:83
 #1 XRandRConfig::applyKScreenConfig at /usr/src/debug/libkscreen-1.0/backends/xrandr/xrandrconfig.cpp:164
 #2 KScreen::Config::setConfig at /usr/src/debug/libkscreen-1.0/src/config.cpp:66
 #3 KScreenDaemon::applyIdealConfig at /usr/src/debug/kscreen-1.0/kded/daemon.cpp:118
 #4 KScreenDaemon::applyConfig at /usr/src/debug/kscreen-1.0/kded/daemon.cpp:98
 #5 QMetaObject::activate at kernel/qobject.cpp:3539
 #7 Device::ready at /usr/src/debug/kscreen-1.0/x86_64-redhat-linux-gnu/kded/moc_device.cpp:112
 #8 setReady at /usr/src/debug/kscreen-1.0/kded/device.cpp:80
 #9 Device::isLaptopFetched at /usr/src/debug/kscreen-1.0/kded/device.cpp:122
 #10 QMetaObject::activate at kernel/qobject.cpp:3539

Comment 1 dte.linux 2013-07-22 07:12:37 UTC
Created attachment 776762 [details]
File: backtrace

Comment 2 dte.linux 2013-07-22 07:12:41 UTC
Created attachment 776763 [details]
File: cgroup

Comment 3 dte.linux 2013-07-22 07:12:45 UTC
Created attachment 776764 [details]
File: core_backtrace

Comment 4 dte.linux 2013-07-22 07:12:50 UTC
Created attachment 776765 [details]
File: dso_list

Comment 5 dte.linux 2013-07-22 07:12:54 UTC
Created attachment 776766 [details]
File: environ

Comment 6 dte.linux 2013-07-22 07:12:58 UTC
Created attachment 776767 [details]
File: limits

Comment 7 dte.linux 2013-07-22 07:13:05 UTC
Created attachment 776768 [details]
File: maps

Comment 8 dte.linux 2013-07-22 07:13:09 UTC
Created attachment 776769 [details]
File: open_fds

Comment 9 dte.linux 2013-07-22 07:13:18 UTC
Created attachment 776770 [details]
File: proc_pid_status

Comment 10 dte.linux 2013-07-22 07:13:23 UTC
Created attachment 776771 [details]
File: var_log_messages

Comment 11 Daniel Vrátil 2013-07-22 16:53:13 UTC
Could you please run "kscreen-console bug" in terminal and attach it's output here? Thanks.

Comment 12 Daniel Vrátil 2013-07-26 08:55:31 UTC

*** This bug has been marked as a duplicate of bug 981624 ***


Note You need to log in before you can comment on or make changes to this bug.