Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 986419 - F19 DNF extremely slow then fails - Curl handle error, unsupported protocol
Summary: F19 DNF extremely slow then fails - Curl handle error, unsupported protocol
Keywords:
Status: CLOSED DUPLICATE of bug 986237
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 19
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-19 17:45 UTC by Gerald Cox
Modified: 2013-07-22 05:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-22 05:43:31 UTC


Attachments (Terms of Use)

Description Gerald Cox 2013-07-19 17:45:25 UTC
Description of problem:
DNF appears to hang, then after about 5 minutes fails with:
Error: Problem with repo 'updates': An Curl handle error: Unsupported protocol

File which appears to be causing the issue is default from F19 install:

[updates]
name=Fedora $releasever - $basearch - Updates
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/updates/$releasever/$basearch/
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=updates-released-f$releasever&arch=$basearch
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch

[updates-debuginfo]
name=Fedora $releasever - $basearch - Updates - Debug
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/updates/$releasever/$basearch/debug/
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=updates-released-debug-f$releasever&arch=$basearch
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch

[updates-source]
name=Fedora $releasever - Updates Source
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/updates/$releasever/SRPMS/
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=updates-released-source-f$releasever&arch=$basearch
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch



Version-Release number of selected component (if applicable):
dnf-0.3.9-1.giteff4c49.fc19.noarch


How reproducible:
Issue dnf upgrade command

Steps to Reproduce:
1. dnf clean all
2. dnf upgrade
3.

Actual results:
Fail, curl handle error

Expected results:
list packages eligible for upgrade

Additional info:

Comment 1 Ales Kozumplik 2013-07-22 05:43:31 UTC
Hi Gerald,

thank you for the report. I noticed this too and narrowed the error down to librepo. See bug 986237.

*** This bug has been marked as a duplicate of bug 986237 ***


Note You need to log in before you can comment on or make changes to this bug.