Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 986237 - downloading the updates repo hangs and errors out recently
Summary: downloading the updates repo hangs and errors out recently
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: librepo
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Tomas Mlcoch
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 986419 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-19 09:50 UTC by Ales Kozumplik
Modified: 2014-09-30 23:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-17 09:46:03 UTC


Attachments (Terms of Use)

Description Ales Kozumplik 2013-07-19 09:50:17 UTC
Tested with the latest librepo HEAD on my local F19 machine and with librepo-0.0.4 on a virtual F19.

The following first hangs then errors out with librepo.LibrepoException: (17, 'Bad checksum', None).

#! /usr/bin/python

import librepo

MIRROR="""https://mirrors.fedoraproject.org/metalink?repo=updates-released-f19&arch=x86_64"""
DESTDIR="./"

if __name__ == "__main__":
    h = librepo.Handle()
    h.destdir = DESTDIR
    h.interruptible = True
    # h.url = URL
    h.repotype = librepo.LR_YUMREPO
    h.mirrorlist = MIRROR
    h.yumdlist = ["primary", "filelists", "prestodelta", "group_gz"]
    # h.local = True
    h.perform(librepo.Result())
    assert(isinstance(h.mirrors, list))

What is going on? If I use the regular fedora librepo it gets downloaded within a second. Please treat this high prio since if it is not isolated to my systems for some reason (?) all DNF users on f19 are getting hitten by it as we speak.

Comment 1 Ales Kozumplik 2013-07-22 05:43:31 UTC
*** Bug 986419 has been marked as a duplicate of this bug. ***

Comment 2 Tomas Mlcoch 2013-07-22 08:38:40 UTC
Hi, I cannot reproduce the issue. I've tried:
* librepo v0.0.4 from f19
* librepo v0.0.5 from rawhide
* librepo HEAD from the git
No success.

I suspect that the cause could be a badly synchronized mirror and the "Bad checksum" error was legitimate.

What do to if this happens next time:
In current released versions of Librepo, there is no easy way to get detailed (debug) output. So the best what you can do is the report the issue to me (add comment to this bug, open the new one, ping me on irc, email, etc).

In the next version of librepo (probably the 0.0.6) there will be a detailed error messages + simple way to set a own debug handler to catch all librepo debug messages.

Comment 3 Tomas Mlcoch 2013-12-17 09:46:03 UTC
Closing this bug, because it was related to an ancient version of librepo.
Currently there is librepo 1.5.0 in f20 and 1.0.0 in f19.
This new versions have a much better error reporting capabilities and fixed a lot of, most likely, related bugs.


Note You need to log in before you can comment on or make changes to this bug.