Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 985978 - Deleting the admin user causes Foreman orchestration errors
Summary: Deleting the admin user causes Foreman orchestration errors
Keywords:
Status: CLOSED DUPLICATE of bug 868910
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: Nightly
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Ivan Necas
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-18 16:18 UTC by Mike McCune
Modified: 2014-05-20 11:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-05-20 11:38:36 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Mike McCune 2013-07-18 16:18:17 UTC
If you try to delete the default 'admin' user created during installation it will fail with either a:

 * Failed to perform additional action KatelloForemanEngine::Actions::UserDestroy: 422 Unprocessable Entity

or 

 *  Failed to perform additional action KatelloForemanEngine::Actions::UserDestroy: 403 Forbidden

We need to allow deleting of any user without error as long as the rules are maintained to have an existing user with Administrator rights within the database.

Comment 1 Dominic Cleal 2013-07-18 16:40:51 UTC
Foreman requires an admin user that it uses for various anonymous actions, e.g. Puppet report uploads, hosts updating their build state and when logins are disabled.  I'm not sure that having this fall back to another user that happens to have admin right would be desirable either, so I'd suggest we still need some sort of anonymous admin user by default for automated actions.

It would make sense though to only allow user-defined users to be able to log in and to have the anonymous admin account locked and unusable.

Comment 3 Dominic Cleal 2014-05-20 11:38:36 UTC

*** This bug has been marked as a duplicate of bug 868910 ***


Note You need to log in before you can comment on or make changes to this bug.