Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 985847 - WiFI AR9485 has problem with signal, and drops connections.
Summary: WiFI AR9485 has problem with signal, and drops connections.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-18 11:22 UTC by Artur Szymczak
Modified: 2013-09-18 20:46 UTC (History)
7 users (show)

Fixed In Version: kernel-3.11.0-0.rc2.git3.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-18 20:46:51 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Linux Kernel 49201 None None None Never

Description Artur Szymczak 2013-07-18 11:22:16 UTC
Description of problem:
I have ASUS UX21E with WiFi AR9485. I have problems with connecting to AP, when I am not ear enough to it. This problem is upstream in kernel, and patch to it is available upstream. Please bugport it to current Fedora kernel.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Artur Szymczak 2013-07-18 11:23:43 UTC
s,bugport,backport,

Comment 2 Artur Szymczak 2013-07-31 04:45:00 UTC
I compiled kernel kernel-3.11.0-0.rc2.git3.1 on F19, and it fixed the problem. So I'm waiting for release kernel 3.11 in Fedora 19.

Comment 3 Artur Szymczak 2013-07-31 04:52:46 UTC
This version (installed from rawhide) also works for me: kernel-3.11.0-0.rc3.git0.1.fc20.x86_64.rpm

Comment 4 Josh Boyer 2013-07-31 12:53:02 UTC
(In reply to Artur Szymczak from comment #2)
> I compiled kernel kernel-3.11.0-0.rc2.git3.1 on F19, and it fixed the
> problem. So I'm waiting for release kernel 3.11 in Fedora 19.

That isn't going to be for another couple of months.

I'm guessing this commit is what fixed things:

commit 9b60b64bfe98b9cc01b21e6126819b11a0f0a971
Author: Sujith Manoharan <c_manoha@qca.qualcomm.com>
Date:   Thu Jun 13 22:51:26 2013 +0530

    ath9k: Add custom parameters for CUS198
    
    CUS198 is a card based on AR9485. There are differences
    between the base reference design HB125 and CUS198.
    Identify such cards based on the PCI subsystem IDs and
    set HW parameters appropriately.
    
    Addresses this bug - https://bugzilla.kernel.org/show_bug.cgi?id=49201
    
    Cc: jkp@iki.fi
    Cc: gfmichaud@gmail.com
    Signed-off-by: Sujith Manoharan <c_manoha@qca.qualcomm.com>
    Signed-off-by: John W. Linville <linville@tuxdriver.com>

John, is that something that is suitable for stable?

Comment 5 John W. Linville 2013-07-31 13:14:43 UTC
It doesn't strike me as the usual type of fix for stable.  It is also a bit larger than I would typically like to see for stable.  OTOH, I have no objection to carrying it in Fedora.

Comment 6 Artur Szymczak 2013-09-03 17:42:45 UTC
As you know, kernel-3.11 is out. Will it be packaged for F19?

Comment 7 Josh Boyer 2013-09-18 20:32:01 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.

Comment 8 Artur Szymczak 2013-09-18 20:45:51 UTC
This kernel is working for me. Thank you.

Comment 9 Josh Boyer 2013-09-18 20:46:51 UTC
Thank you for letting us know.


Note You need to log in before you can comment on or make changes to this bug.