Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 985833 - Dist-geo-rep : Geo-rep commands won't work if the state_file is changed using config between create and start of geo-rep session.
Summary: Dist-geo-rep : Geo-rep commands won't work if the state_file is changed using...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication
Version: 2.1
Hardware: x86_64
OS: Linux
high
medium
Target Milestone: ---
: ---
Assignee: Avra Sengupta
QA Contact: Vijaykumar Koppad
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-18 10:54 UTC by Vijaykumar Koppad
Modified: 2014-08-25 00:50 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.4.0.15rhs-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-23 22:38:45 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Vijaykumar Koppad 2013-07-18 10:54:25 UTC
Description of problem: None of the geo-rep commands work, if the state_file is changes using the geo-rep config to some nonexistent file, in between create and start of geo-rep.


Version-Release number of selected component (if applicable):3.4.0.12rhs.beta4-1.el6rhs.x86_64


How reproducible:Happens everytime.


Steps to Reproduce:
1.Create a geo-rep relationship between master and slave.
2.Change the state_file using geo-rep config command to some non existent file 
3.try geo-rep start command 

Actual results: After the state_file change none of the geo-rep commands work.


Expected results: Config change at any stage shouldn't affect any of the geo-rep commands.


Additional info:

Comment 2 Avra Sengupta 2013-07-22 08:46:22 UTC
Resolved in https://code.engineering.redhat.com/gerrit/#/c/10452/

Comment 3 Vijaykumar Koppad 2013-08-12 09:19:43 UTC
verified on glusterfs-3.4.0.18rhs-1.el6rhs.x86_64

Comment 4 Scott Haines 2013-09-23 22:38:45 UTC
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Comment 5 Scott Haines 2013-09-23 22:41:29 UTC
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html


Note You need to log in before you can comment on or make changes to this bug.