Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 985829 - need current version packaged (2.10)
Summary: need current version packaged (2.10)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ykclient
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dennis Gilmore
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-18 10:41 UTC by John Dennis
Modified: 2014-03-24 06:44 UTC (History)
3 users (show)

Fixed In Version: ykclient-2.12-1.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-24 06:40:48 UTC


Attachments (Terms of Use)

Description John Dennis 2013-07-18 10:41:41 UTC
The ykclient package is out of date. The currently packaged version is 2.7, released 2 years ago. The current version is 2.10 released 2 months ago.

FreeRADIUS 3.0 has added yubikey support but it's failing to build because it's missing the ykclient_request_process symbol in libykclient.

Would you please package the new version for F18, F19 and rawhide.

Thank you.

Comment 1 Fedora End Of Life 2013-12-21 14:21:11 UTC
This message is a reminder that Fedora 18 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 18. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '18'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 18's end of life.

Thank you for reporting this issue and we are sorry that we may not be 
able to fix it before Fedora 18 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior to Fedora 18's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 2 John Dennis 2013-12-23 15:13:08 UTC
F20 still has version the old 2.7 version, please package the current version.

Comment 3 Fedora Update System 2014-03-13 22:29:23 UTC
ykclient-2.12-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/ykclient-2.12-1.fc20

Comment 4 Fedora Update System 2014-03-13 22:29:32 UTC
ykclient-2.12-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ykclient-2.12-1.fc19

Comment 5 John Dennis 2014-03-14 02:09:19 UTC
Nick, now that ykclient has been updated you can enable the yubikey support in the freeradius spec file. Please do this for F20 and rawhide.

Comment 6 Fedora Update System 2014-03-15 15:01:54 UTC
Package ykclient-2.12-1.fc19, pam_yubico-2.14-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ykclient-2.12-1.fc19 pam_yubico-2.14-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-3826/pam_yubico-2.14-1.fc19,ykclient-2.12-1.fc19
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2014-03-24 06:40:48 UTC
ykclient-2.12-1.fc20, pam_yubico-2.14-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2014-03-24 06:44:50 UTC
ykclient-2.12-1.fc19, pam_yubico-2.14-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.