Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 985770 - [vdsm] AttributeError: GuestAgent instance has no attribute '_sock' during vmDestroy. VM is stuck in 'Powering down(not responding)' state
Summary: [vdsm] AttributeError: GuestAgent instance has no attribute '_sock' during vm...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.2.0
Hardware: x86_64
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.3.0
Assignee: Vinzenz Feenstra [evilissimo]
QA Contact: Pavel Novotny
URL:
Whiteboard: virt
: 1081275 (view as bug list)
Depends On: 1011608
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-18 08:23 UTC by Elad
Modified: 2018-12-05 16:10 UTC (History)
10 users (show)

Fixed In Version: is8
Doc Type: Bug Fix
Doc Text:
When the guest agent socket could not be created, VDSM could prevent the release of the virtual machine, so the virtual machine is stuck in a powering down and unresponsive state. Now, when the guest agent socket is not created, VDSM will kill the virtual machine process and restart the VDSM service, and log the occurrence.
Clone Of:
Environment:
Last Closed: 2014-01-21 16:29:05 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)
logs (deleted)
2013-07-18 08:23 UTC, Elad
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 767853 None None None Never
Red Hat Product Errata RHBA-2014:0040 normal SHIPPED_LIVE vdsm bug fix and enhancement update 2014-01-21 20:26:21 UTC
oVirt gerrit 17072 None None None Never

Description Elad 2013-07-18 08:23:52 UTC
Created attachment 775185 [details]
logs

Description of problem:
I tried to power-off a VM and it failed with:

Thread-99::ERROR::2013-07-18 10:17:41,564::BindingXMLRPC::932::vds::(wrapper) unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/BindingXMLRPC.py", line 918, in wrapper
    res = f(*args, **kwargs)
  File "/usr/share/vdsm/BindingXMLRPC.py", line 194, in vmDestroy
    return vm.destroy()
  File "/usr/share/vdsm/API.py", line 315, in destroy
    res = v.destroy()
  File "/usr/share/vdsm/libvirtvm.py", line 2654, in destroy
    response = self.releaseVm()
  File "/usr/share/vdsm/libvirtvm.py", line 2606, in releaseVm
    self.guestAgent.stop()
  File "/usr/share/vdsm/guestIF.py", line 219, in stop
    self._channelListener.unregister(self._sock.fileno())
AttributeError: GuestAgent instance has no attribute '_sock'



Version-Release number of selected component (if applicable):
vdsm-4.10.2-23.0.el6ev.x86_64

How reproducible:
happened to me once

Steps to Reproduce:
1. power-off a VM

Actual results:
vdsm fails to power-off the VM:
AttributeError: GuestAgent instance has no attribute '_sock'

Expected results:
VM power-off (destroy) should work properly


Additional info:
logs

Comment 1 Elad 2013-07-18 11:38:09 UTC
This VM was migrated from a 3.3 host (vdsm-4.11.0-121.git082925a.el6.x86_64) to a 3.2 host (vdsm-4.10.2-23.0.el6ev.x86_64).

After that, vdsm reports that it does not get statistics from libvirt about this VM (forever):
'monitorResponse': '-1'

Comment 2 Vinzenz Feenstra [evilissimo] 2013-07-31 08:30:58 UTC
Merged to u/s master and is included in oVirt 3.3 VDSM branch
http://gerrit.ovirt.org/gitweb?p=vdsm.git;a=commit;h=d0469591a5147d6b9920528a0c6b953723888957

Comment 4 Pavel Novotny 2013-10-17 15:04:00 UTC
Verified in vdsm-4.13.0-0.2.beta1.el6ev.x86_64 (is18).

Verification steps:
1) create new VM
2) migrate it from one 3.3 host to another 3.3 host (related to comment 1)
3) power off the VM

VM was powered off successfully, no error message in webadmin and no errors in VDSM logs on both hosts.

Comment 6 Charlie 2013-11-28 00:33:21 UTC
This bug is currently attached to errata RHBA-2013:15291. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.

Comment 8 errata-xmlrpc 2014-01-21 16:29:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0040.html

Comment 9 David Gibson 2014-04-02 00:13:22 UTC
*** Bug 1081275 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.