Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 985763 - can't set input source keyboard shortcuts
Summary: can't set input source keyboard shortcuts
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: cinnamon
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: leigh scott
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 986061 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-18 08:10 UTC by Jonathan Kamens
Modified: 2014-03-11 20:03 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-18 08:50:09 UTC


Attachments (Terms of Use)

Description Jonathan Kamens 2013-07-18 08:10:38 UTC
In Cinnamon, when I open Region & Language settings and click Options, it says both the "Switch to previous source" and "Switch to next source" keyboard shortcuts are set to Shift-Ctrl-Space. I'm not sure how two different shortcuts can be set to the same thing, and indeed, when I type Shift-Ctrl-Space nothing happens.

It also says, "You can change these shortcuts in the keyboard settings," but when I look in the keyboard settings, there are no shortcuts to be set there for switching among input sources.

Comment 1 leigh scott 2013-07-18 08:50:09 UTC



Cinnamon doesn't use the new keybindings in gnome Region & Language settings.
Cinnamon uses Alt-Shift to switch input source.

It can be changed, here's a list of valid key combos


$ gsettings range org.gnome.settings-daemon.peripherals.keyboard input-sources-switcher
enum
'off'
'shift-l'
'alt-l'
'ctrl-l'
'shift-r'
'alt-r'
'ctrl-r'
'alt-shift-l'
'alt-shift-r'
'ctrl-shift-l'
'ctrl-shift-r'
'shift-l-shift-r'
'alt-l-alt-r'
'ctrl-l-ctrl-r'
'alt-shift'
'ctrl-shift'
'alt-ctrl'
'caps'
'shift-caps'
'alt-caps'
'ctrl-caps'


To set

gsettings set org.gnome.settings-daemon.peripherals.keyboard input-sources-switcher 'alt-shift'

Then logout for the change to take affect.

Comment 2 Jonathan Kamens 2013-07-18 09:02:29 UTC
Isn't it a bug that the Region & Language settings dialog told me to change the binding somewhere where I can't actually change it?

Isn't it a bug that there is no GUI for changing this binding?

Comment 3 leigh scott 2013-07-18 22:01:08 UTC
*** Bug 986061 has been marked as a duplicate of this bug. ***

Comment 4 Leonid Kanter 2013-07-19 15:31:43 UTC
Following arguments do not work:

'ctrl-shift'
'ctrl-shift-l'
'ctrl-shift-r'

Other arguments like 'caps' 'shift-caps' are ok.


Note You need to log in before you can comment on or make changes to this bug.