Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 985678 - tycho: Does not work with Maven 3.1.0
Summary: tycho: Does not work with Maven 3.1.0
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: tycho
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Roland Grunberg
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 985674
TreeView+ depends on / blocked
 
Reported: 2013-07-18 04:39 UTC by Mikolaj Izdebski
Modified: 2013-07-25 13:29 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-25 13:29:33 UTC


Attachments (Terms of Use)
Maven build log (deleted)
2013-07-23 15:19 UTC, Mikolaj Izdebski
no flags Details


Links
System ID Priority Status Summary Last Updated
Eclipse Project 406056 None None None Never

Description Mikolaj Izdebski 2013-07-18 04:39:44 UTC
Description of problem:
Tycho 0.18.0 is known not to work with Maven 3.1.0.  As I want to update Maven to 3.1.0 in Fedora this bug needs to be resolved ASAP.

Upstream has added experimental support for maven 3.1.0 in version 0.19.0.  Please update to that version or backport the patch.

Version-Release number of selected component (if applicable):
0.18.0

Comment 1 Krzysztof Daniel 2013-07-18 12:31:24 UTC
Hey Mikolaj,

Tycho staged a version 0.18.1, which I built for rawhide [1]. Does it solve the problem?

[1] http://koji.fedoraproject.org/koji/buildinfo?buildID=435563

Comment 2 Mikolaj Izdebski 2013-07-18 12:40:41 UTC
I can't confirm that yet.  Upgrade to Maven 3.1.0 is a big effort, which will have to wait for a bit -- I don't even know if it will make into Fedora 20.  For now I just wanted to give you heads up so that you have time to work on upgrade.

Comment 3 Krzysztof Daniel 2013-07-18 12:46:36 UTC
After chat with Mikolaj, closing as RAWHIDE.

Comment 4 Krzysztof Daniel 2013-07-18 12:46:56 UTC
After chat with Mikolaj, closing as RAWHIDE.

Comment 5 Mikolaj Izdebski 2013-07-23 15:18:10 UTC
Maven 3.1.0 is available in rawhide now.  I tried using Tycho with it ans it fails because it tried to use Sonatype Aether.

Tycho most likely needs to be ported to Eclipse Aether, which should be as easy as s/org.eclipse.aether/org.sonatype.aether/g in java files and POMs.

Maven build log with tycho failure attached.

Comment 6 Mikolaj Izdebski 2013-07-23 15:19:20 UTC
Created attachment 777362 [details]
Maven build log

Comment 7 Krzysztof Daniel 2013-07-24 07:52:57 UTC
Investigating. The problem is caused by one of the patches which introduces eather imports.

Comment 8 Roland Grunberg 2013-07-24 15:09:20 UTC
After speaking with Krzysztof, and Mikolaj, I'll take care of this. I'll try to have this completed as soon as I can.

Comment 9 Roland Grunberg 2013-07-24 21:07:00 UTC
tycho-0.18.1-2.fc20 (http://koji.fedoraproject.org/koji/buildinfo?buildID=437615) now uses latest Eclipse Aether, and Maven 3.1.0.

Comment 10 Mikolaj Izdebski 2013-07-25 05:24:36 UTC
Confirmed. Works for me.

Comment 11 Krzysztof Daniel 2013-07-25 07:47:33 UTC
Confirmed (built eclipse and eclipse-ptp).

Comment 12 Roland Grunberg 2013-07-25 13:29:33 UTC
Marking as CLOSED (RAWHIDE). There are still some bug fixes/improvements to be made (tracked under Tycho component).


Note You need to log in before you can comment on or make changes to this bug.